Jump to content
TorGuard
  • 0
Thor

Tor Client Freeze. Loss of internet until restart.

Rate this question

Question

So I am still having this issue even though I am on the latest client v0.3.60. This has been happening since v0.3.51 several months ago. I would randomly lose internet connection while through VPN and the client would be nonresponsive. I force close Torguard client through task manager but my internet connection does not restore itself. My Network icon in the taskbar shows connectivity but when I use the Windows troubleshoot problems function it would tell me that Windows could not automatically detect this network's proxy. I will not be able to open up a web page in any browser. Internet will restore after I restart but sometimes I would have to do a reset because Windows 10 will get stuck on the Restart screen, which only happens when the client freezes like this and I have to use task manager to end it. This is just a huge pain to deal with. What is happening that is causing the client to hang like this? How can I restore internet without having to restart my PC every time?

Share this post


Link to post
Share on other sites

15 answers to this question

Recommended Posts

  • 0

I've uninstalled reinstalled several times over the past few months. It doesn't help. The arm killswitches after first successful connection is checked.

Share this post


Link to post
Share on other sites
  • 0

I've uninstalled reinstalled several times over the past few months. It doesn't help. The arm killswitches after first successful connection is checked.

 

Disable the killswitch feature to see if that stops the freezing problem upon disconnecting.

 

 

  • Here is some stuff you should check:
    • Ensure Windows is fully up to date
    • Ensure Windows has no malware or viruses
    • Ensure TorGuard isn't being blocked by any third-party antivirus/firewall programs; if you do have these installed, try disabling them for a short time to see if you experience the same problems again.
  • To check "Windows could not automatically detect this network's proxy" problem
    • Open runbox with Winkey+R
    • Enter: inetcpl.cpl
    • Click the Connections tab
    • Click LAN Settings
    • Ensure "Automatically detect settings" is checked
    • Ensure "Use a proxy server for your LAN" is unchecked
    • g7MJ8dm.png
  • Reset your NET
    • Press Win+X
    • Click Command Prompt (Admin)
    • Type netsh winsock reset
    • Type netsh int ipv4 reset
    • Type netsh int ipv6 reset
    • Reboot

 

That's all I can think of at the moment, TorGuard support should be able to help you better, open a ticket to get fast response from them.

 

 

Edit: TorGuard killswitch setting will disable your network device if it loses connection and will re-enable it when you try to connect to VPN. To check if your network interface is disabled the next time you lose internet access:

  1. Press WinKey+R
  2. Type ncpa.cpl
  3. If your primary interface is disabled, re-enable it, should restore your internet.

 

Edit2: I just noticed you said you killed the "TorGuard Client" via the task manager, but no mention of "openvpn.exe"; make sure this is also terminated too during next freeze up.

Edited by TorGuard

Share this post


Link to post
Share on other sites
  • 0

I've done 2 and 3 before. 3 is sort of pointless as I regain internet after I restart anyway. I really just don't want to have to restart every time this happens. I do have a ticket open with them but their response is always a workaround, which haven't been helpful so far, rather than getting to the root of the problem.

Share this post


Link to post
Share on other sites
  • 0

I've done 2 and 3 before. 3 is sort of pointless as I regain internet after I restart anyway. I really just don't want to have to restart every time this happens. I do have a ticket open with them but their response is always a workaround, which haven't been helpful so far, rather than getting to the root of the problem.

 

Do you still get freeze ups or loss of internet with the "arm killswitches" setting disabled?

Do you have an anti-virus or firewall installed?

 

Check the last two edits I made at the bottom of my previous post.

 

 

Edit: This might help:

https://support.microsoft.com/en-ca/help/10741/windows-10-fix-network-connection-issues

Edited by TorGuard

Share this post


Link to post
Share on other sites
  • 0

I've done 2 and 3 before. 3 is sort of pointless as I regain internet after I restart anyway. I really just don't want to have to restart every time this happens. I do have a ticket open with them but their response is always a workaround, which haven't been helpful so far, rather than getting to the root of the problem.

 

Hello,

 

It might be best you ask for a remote session so we can logon and take a look - if you want to arrange this let me know and we can get one scheduled in for you.

 

Regards

Share this post


Link to post
Share on other sites
  • 0

This happens to me too. Apparently it stopped after disabling the kill switch. If you want I can send some files to help fix the issue. I use win10.

Share this post


Link to post
Share on other sites
  • 0

This happens to me too. Apparently it stopped after disabling the kill switch. If you want I can send some files to help fix the issue. I use win10.

 

 

Do you still get freeze ups or loss of internet with the "arm killswitches" setting disabled?

Do you have an anti-virus or firewall installed?

 

Check the last two edits I made at the bottom of my previous post.

 

 

Edit: This might help:

https://support.microsoft.com/en-ca/help/10741/windows-10-fix-network-connection-issues

I will disable the killswitch and see if it happens again. The thing is these internet connection problems happen so randomly that sometimes I have to go weeks before it happens again and sometimes it'll happen a few times a week. I have Norton 360 installed but I am not going to disable it during my VPN connections potentially for a week or more.

 

I will also try to end the openvpn.exe next time and see if it restores connection.

Share this post


Link to post
Share on other sites
  • 0

This happens to me too. Apparently it stopped after disabling the kill switch. If you want I can send some files to help fix the issue. I use win10.

 

Good to know, what modifications or "files" fix the issue?

 

I will disable the killswitch and see if it happens again. The thing is these internet connection problems happen so randomly that sometimes I have to go weeks before it happens again and sometimes it'll happen a few times a week. I have Norton 360 installed but I am not going to disable it during my VPN connections potentially for a week or more.

 

I will also try to end the openvpn.exe next time and see if it restores connection.

 

Anti-viruses are known to prevent programs from accessing certain system resources, such as network devices; Norton may think TorGuard is trying to do something malicious and block access: which might explain the freezes. Check the logs, also disable Norton temporarily and test if client freezes to rule it out for future reference.

Share this post


Link to post
Share on other sites
  • 0

No files fixed it. I just disabled the kill switch. When I mentioned sending files, I was referring to sending logs or whatever TorGuard team would request.

 

However it happened again today, even with the kill switch disabled

Share this post


Link to post
Share on other sites
  • 0

No files fixed it. I just disabled the kill switch. When I mentioned sending files, I was referring to sending logs or whatever TorGuard team would request.

 

However it happened again today, even with the kill switch disabled

 

Hey dramm

 

Do you by chance disconnect the vpn just by closing the application ? this is normally a symptom of our internal DNS being left on your network adapter - the only way that happens is if you if you just lose the app without hitting disconnect.

 
Please go to more settings --> Network Tab --> Set the DNS as below:
 
At Application Start: OpenDNS
While establishing: OpenDNS
When VPN is connected: OpenDNS
 
Restart TG Client and retest - let me know if it happens again.
 
Regards

Share this post


Link to post
Share on other sites
  • 0

No files fixed it. I just disabled the kill switch. When I mentioned sending files, I was referring to sending logs or whatever TorGuard team would request.

 

However it happened again today, even with the kill switch disabled

 

 

TorGuard VPN Client has logging disabled, so there will be no files available to send. However, you can enable it by doing the following:

  1. Press WinKey+R to bring runbox up.
  2. Type: %LOCALAPPDATA%\VPNetworkLLC\TorGuard\configs
  3. Open the .ovpn location file(s) that you use, I recommend using Notepad++ to edit text files.
  4. Paste the following at the bottom of file:
    #LOGGING
    verb 4
    status TorGuard.USA-Chicago-NO-TORRENTS-UDP_status_log.log
    log-append TorGuard.USA-Chicago-NO-TORRENTS-UDP_log.log
    
  5. Replace TorGuard.USA-Chicago-NO-TORRENTS-UDP with the filename of the .ovpn you are editing.
  6. Save the file.
  7. Reconnect to the VPN Location you edited.
  8. Logs will be saved at the same location as the configuration files.
  9. When you experience a freeze up again, upload the two logs(status_log and log) to a support ticket.

 

Alternatively, it might be a viable solution to allow Support to assist you remotely if all else fails.

Share this post


Link to post
Share on other sites
  • 0

I had this issue until I unchecked Killer Networks Bandwidth Control under my Network on both the native NIC and the VPN Nic in Network Manager. To be specific. On Windows 10, Search "Network", then click "View Network Connections", right click on your adapter that is connecting to Internet, in my case: "Wi-Fi", Goto "Properties". Uncheck anything related to "[Killer] Bandwidth Control". Do the same for TAP-Windows Adapter. Then restart and try your tunnel again. This totally repaired my issues.

Share this post


Link to post
Share on other sites
  • 0

I had this issue until I unchecked Killer Networks Bandwidth Control under my Network on both the native NIC and the VPN Nic in Network Manager. To be specific. On Windows 10, Search "Network", then click "View Network Connections", right click on your adapter that is connecting to Internet, in my case: "Wi-Fi", Goto "Properties". Uncheck anything related to "[Killer] Bandwidth Control". Do the same for TAP-Windows Adapter. Then restart and try your tunnel again. This totally repaired my issues.

 

Thanks for sharing. You should also uninstall any extra Killer software and only install the network driver for your device: http://www.killernetworking.com/driver-downloads — under Other Downloads. I read the extra software does more harm then good from various different online sources.

Share this post


Link to post
Share on other sites
  • 0

When it disconnects and the client becomes non-responsive, you'd just need to re-enable the network adapter. 

 

I use the following batch script...

@ECHO OFF

ECHO Restarting TorGuard adapter...
netsh interface set interface "TorGuard" DISABLED
timeout /T:5>nul
netsh interface set interface "TorGuard" ENABLED

EXIT

You need to rename the network adapter to "TorGuard" or whatever.  Change it accordingly in the script.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×