Jump to content
TorGuard
  • 1
jrt3a

Torguard client unreliable

Rate this question

Question

Hi,

 

For the past month or so the torguard client has been shutting down without notice.  I'm running windows 10.  Nothing significant has changed in my system configuration that would have triggered this problem, as far as I know.

 

Perhaps unrelated: growing tired of this problem, I tried to use the OpenVPN client instead.  But at some point, without disconnection, it starts leaking my IP through webRTC according to ipleak.net, though I have the chrome extension webRTC network limiter installed.

 

Can you please help me address one or both of these problems?

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

After a format re-install of Windows and a new Security agent (Kaspersky now instead of Comodo) this is still happening.

 

Torguard crashed twice within 15 minutes; after 6 days of no issues.

I am using an app re-starter to restart the client when it crashes.  

 

I had 2 separate crashes yesterday, and both coincided with the following event in the System event log:

 

Event ID: 8033

Event Source: BROWSER

The browser has forced an election on network \Device\NetBT_Tcpip_{7A60A590-4223-43CB-BE38-A4747AA98B82} because a master browser was stopped.

 

 

(This guid is associated with Junos Pulse)

 

There are other instances in the event log with the same information, so the event is not an issue in of itself, but could alert to another issue.  This event was logged on or just before the app restart picked up that the VPN client had crashed.

 

Windows 10: 1703 (15063.483)

Torguard: v0.3.69

 

I will keep monitoring.

Share this post


Link to post
Share on other sites
  • 0

Another disconnect event on Friday (After uptime of 3 days).

 

Coincided with another event logged:

(Again other similar events are logged at other times where the VPN does not crash)

 

Event ID: 8033

Event Source: BROWSER

The browser has forced an election on network \Device\NetBT_Tcpip_{C8F5B07D-BB4D-4BB8-8043-D5FB41C906D2} because a master browser was stopped.

 

This GUID refers to the Ethernet adaptor created by TAP-Windows-Adaptor V9

Share this post


Link to post
Share on other sites
  • 0

After a format re-install of Windows and a new Security agent (Kaspersky now instead of Comodo) this is still happening.

 

Torguard crashed twice within 15 minutes; after 6 days of no issues.

I am using an app re-starter to restart the client when it crashes.  

 

I had 2 separate crashes yesterday, and both coincided with the following event in the System event log:

 

Event ID: 8033

Event Source: BROWSER

The browser has forced an election on network \Device\NetBT_Tcpip_{7A60A590-4223-43CB-BE38-A4747AA98B82} because a master browser was stopped.

 

 

(This guid is associated with Junos Pulse)

 

There are other instances in the event log with the same information, so the event is not an issue in of itself, but could alert to another issue.  This event was logged on or just before the app restart picked up that the VPN client had crashed.

 

Windows 10: 1703 (15063.483)

Torguard: v0.3.69

 

I will keep monitoring.

 

This isn't actually an error -it’s a normal - can i ask if you have any other vpn apps installed if so please uninstall them, If you remove Kaspersky and reboot - are you able to reproduce this problem?

 

 

Regards

Share this post


Link to post
Share on other sites
  • 0

Hi

 

I've been experiencing freezing issues with the new and latest tor client eg release July 28 2017, you can't disconnect and so you have to exit the client which then means you mess up your connection other symptoms are the task bar freezes, has anybody else had this type of behaviour because I experienced previously and the symptoms are the same as the user from this forum posting, it's the same type of behaviour and I'm using a fresh installation of windows 10 without any third party non windows software installed so if anybody experiences anything else like this it would help because I don't know if it's some problem unique to me or if it is a glitch in the client, thanks

 

https://torguard.net/forums/index.php?/topic/994-tor-client-freeze-loss-of-internet-until-restart/?hl=freezing&do=findComment&comment=4557

Share this post


Link to post
Share on other sites
  • 0

Hi Guys.

 

Thought i'd return as this is still an issue for me, in my original message i said i was on the cusp of renewing for a year and it was a leap of faith that it would get fixed. Kinda waited out a few versions. Also asked a staff meber to connect to me as he offered to connect to another user but the user said no, that's cool, so i offered but staff member said they don't do that! Do i don't know.

 

Well we are up to 0.3.71 and this issue still occurs, happened today.

 

1. Someone said they think it happened when they lost internet, i did think this as well but decided it can't be as i'm sitting here using the internet on other machines that don't have the VPN and if internet dropped, i would have known.

 

2. I thought maybe it happened if i stressed the connections bit, like it seems to happen more if i start up say 5 torrents at once, seems to increase the chance of it happening, even though i set deluge to a lower number of allowed connections.

 

I'm still on a very fresh install of windows 10, this is a download machine and runs very little else.

 

Would a hijack this log still help? Did someone wish to connect to my laptop remotely and look?

 

Someone else above said they use a app relauncher? How are you doing that?

Share this post


Link to post
Share on other sites
  • 0

Hi Guys.

 

Thought i'd return as this is still an issue for me, in my original message i said i was on the cusp of renewing for a year and it was a leap of faith that it would get fixed. Kinda waited out a few versions. Also asked a staff meber to connect to me as he offered to connect to another user but the user said no, that's cool, so i offered but staff member said they don't do that! Do i don't know.

 

Well we are up to 0.3.71 and this issue still occurs, happened today.

 

1. Someone said they think it happened when they lost internet, i did think this as well but decided it can't be as i'm sitting here using the internet on other machines that don't have the VPN and if internet dropped, i would have known.

 

2. I thought maybe it happened if i stressed the connections bit, like it seems to happen more if i start up say 5 torrents at once, seems to increase the chance of it happening, even though i set deluge to a lower number of allowed connections.

 

I'm still on a very fresh install of windows 10, this is a download machine and runs very little else.

 

Would a hijack this log still help? Did someone wish to connect to my laptop remotely and look?

 

Someone else above said they use a app relauncher? How are you doing that?

 

Hello,

 

These issues don't seem to relate to the TorGuard client - connections freezing while using torrents we find is more to do with security software, settings or even modem/router related - we do not see this issue much at all to think there's a real issue with the TG Client.

 

We can certainly login and take a look, just let me know a time your free, you can send your TM details to email sysadmin(at)torguard(dot)net and refer to this thread.

 

Regards

Share this post


Link to post
Share on other sites
  • 0

I can confirm that I am experiencing exactly this issue described by Aiban.

 

I have been experiencing it for about 1.5 years, with no help.  I just tolerate it.  I have to restart my computer once every 2-3 days.  I find myself browsing websites and realizing after the fact that I am not protected.  Disturbing.

 

This is absolutely a problem with the TG Client.  I am on a fresh W10 installation, fresh TG client installation, running the newest TAPs drivers.  Let me re-iterate - I have had TG Client installed on 3 separate Windows machines, ranging from W7 - W8.1 - W10.  I experienced this intermittent but consistent issue in every single installation I have had.

Share this post


Link to post
Share on other sites
  • 0

I am another customer that MUST complain. I've read this thread and must agree with OP. Actually had this happen last night with incident. I have been running Torguard (latest client) and have had it quit, unexpectedly and without warning. It's been doing this for about a year and gives no warning. Also, I've never complained about it until now. Sorry, I'm not that computer literate to have pulled logs.

Share this post


Link to post
Share on other sites
  • 0
On 20/06/2017 at 4:52 PM, JohnVK said:

Dear Admin,

 

The fact that users don't complain doesn't necessarily mean the problem isn't there ;) many users just accept it when it happens. I am one of those, actually.

 

I used to have the TorGuard client crash on me several times a week (absolutely randomly) but usually only when it had been running for over 24 hours. The problem was, when the app crashed the kill switch obviously didn't fire either, leaving me completely open on my actual IP Address... not exactly awesome...

 

There were no log entries present. So there was nothing to troubleshoot on my end. And doing anything pro-actively is quite difficult as well, since the app crashes randomly. There's no telling when this problem will occur...

 

In the end I "solved" my problem by just not running the TorGuard client for very long lengths of time. So... not actually a solution at all.

 

Have to say though, the latest version does not seem to crash on me anymore. But that may also have to do with the fact that I rarely leave it running for more than a couple of hours anymore.

 

Hi John,

We did investigate this and to this day have not found any way to reproduce this random crash, we have seen torguard running for weeks on end without a hiccup when testing, we do have a large user base and so there would be a lot more people reporting this problem if it was an issue with TG - if you can catch when it happens with debugging enabled and provide as much info as possible it would be very helpful

Regards

Share this post


Link to post
Share on other sites
  • 0
On 6/17/2018 at 4:27 PM, ll3 said:

I am another customer that MUST complain. I've read this thread and must agree with OP. Actually had this happen last night with incident. I have been running Torguard (latest client) and have had it quit, unexpectedly and without warning. It's been doing this for about a year and gives no warning. Also, I've never complained about it until now. Sorry, I'm not that computer literate to have pulled logs.


Do you use OpenConnect?

Do you use it on a laptop?

I have problems that when I use TorGuard for a while, I remove my laptop power adapter from the laptop, the app crashes. Weird.

Share this post


Link to post
Share on other sites
  • 0

This has been happening to me too.  The VPN automatically closes every once in a while.  Whats even worse it does not activate the killswitch or close the browser. 

Share this post


Link to post
Share on other sites
  • 0
On 26/07/2018 at 2:45 AM, Random1 said:

This has been happening to me too.  The VPN automatically closes every once in a while.  Whats even worse it does not activate the killswitch or close the browser. 

 

What version of Tg are you running? what OS are you running? are you running security software?

Regards

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×