Jump to content
TorGuard
  • 0
Sign in to follow this  
jackharvest

Linux Mint 18 & Torguard Woes: Disabling TorGuard Client Does Not Restore Regular Connectivity.

Rate this question

Question

jackharvest

Ok, so, I've re-installed Linux Mint 18 about 6 times, and I've finally figured out at what step my connectivity get's completely killed:  After installing TorGuard, and then after disabling it after having had it enabled.

 

Expected Behavior (Linux Mint 17.3 did this): After using TorGuard, click disconnect on the TorGuard client. Normal network connectivity is restored.

 

Current Behavior (Linux Mint 18 does this): After using TorGuard, click disconnect on the TorGuard client. Normal network connectivity is not restored. Websites cannot be browsed. Teamviewer has no connection. Checking for updates yields in a "red X" icon indicating no internet. 

 

I will note that I can still VNC into port 5900 while on my local network when this is down and not working, but my description above for what is not working is still accurate, even when VNC'd in. My network connection is "manual", and I have a static IP, Netmask, Gateway, and Google DNS. This works just fine until I install TorGuard and then disconnect after a happily VPN'd session on the machine.

 

Here's a thread I found (it's recent and relavant) on the LinuxMint forums in regards to this exact issue. Just thought I'd make devs aware on the Torguard end, since it might be something we can change on this end to help ensure reliability.

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0
jackharvest

Current Workaround: (note: having your password in a script is bad practice - please assume that you are the only one with access before doing this)

 

1). Create a text file, and add the following:

 

$echo "yourpassword" | sudo -S sh -c "echo nameserver 8.8.8.8 > /etc/resolv.conf"

 

2). Save the file with .sh as the extension.

 

3). Disconnect from TorGuard, and select the scripts tab up top. Click browse next to the last option, and find your script to run when TorGuard disconnects.

 

Synopsis... TorGuard jacks up your resolv.conf file and it needs to be edited after disconnect every dang time using this script. Hopefully TorGuard can help this have a resolution that doesn't involve the user in the future.

Share this post


Link to post
Share on other sites
  • 0
rr0ss0rr

I think you can prevent this (Until its fixed) by disabling the "Prevent DNS Leak" option in TorGuard Lite.  You can also bypass the password situation by creating the script, changing the owner to root and permissions to 400 (to protect the integrity of the script). Then visudo and add NOPASSWD option to the absolute path to this script (So you can call the script without a password via sudo).  You can automate this with Connect and Disconnect scripts that you call from the client.

 

This is what I do, I reset my DNS to 104.223.91.194 104.223.91.210 8.8.8.8 8.8.4.4 (Yes, I still utilize their DNS even when disconnected) and other things I don't want running through a script that gets called at disconnect time.

Share this post


Link to post
Share on other sites
  • 0
Support

Hey guys, this is fixed in the release coming within the next 3 days.

 

Regards

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×