Jump to content
TorGuard
  • 0

Internet access only working when connected to VPN

Rate this question


culbright

Question

culbright

Recently my Macbook Air can only access the internet when connected via VPN. When I am not running TorGuard and connected to VPN I cannot access anything on the internet. It seems like DNS issue but I cannot say for certain. This began recently and may be related to a forced shutdown during a VPN session.

 

Help please!!

Link to post
Share on other sites

14 answers to this question

Recommended Posts

  • 0
culbright

Hi,

 

I am running v0.3.50 but my issue was resolved earlier today by tech support. My DNS settings were not working and it may have had nothing at all to do with TorGuard software.

 

Thanks.

Link to post
Share on other sites
  • 0

hello happens to me the same torguar overwrites the file resolv.conf and I lose internet connection when not torguar use, and I have to restart the file after using torguard .. is there any solution to tprguar not overwrite the file resolv.conf I am running ubuntu v0.3.50 16.04lts

Link to post
Share on other sites
  • 0

hello happens to me the same torguar overwrites the file resolv.conf and I lose internet connection when not torguar use, and I have to restart the file after using torguard .. is there any solution to tprguar not overwrite the file resolv.conf I am running ubuntu v0.3.50 16.04lts

 

Hello, are you running the latest TG Client 0.3.51 ? please try uncheck the DNS Leak Prevention - let me know if this solves the problem (internal DNS is still pushed by the VPN server).

 

 

Regards

Link to post
Share on other sites
  • 0

Hello, are you running the latest TG Client 0.3.51 ? please try uncheck the DNS Leak Prevention - let me know if this solves the problem (internal DNS is still pushed by the VPN server).

 

Hi. Can you please explain how DNS Leak Prevention works? I'm trying to prevent it by setting TG servers, but have no luck to automate it properly. Some thoughts are posted https://torguard.net/forums/index.php?/topic/879-dns-configuration-with-after-connect-script/

Link to post
Share on other sites
  • 0

Hello, are you running the latest TG Client 0.3.51 ? please try uncheck the DNS Leak Prevention - let me know if this solves the problem (internal DNS is still pushed by the VPN server).

 

 

Regards

 

I am using 0.3.52 on Linux and have the same issue. It looks like nameservers added to resolve.conf by torguard stay in there and then don't work without being connected to the VPN. I get round it by having a version of resolve.conf that has my normal nameservers in and I just copy it back in when I log off torgaurd. Unchecking DNS Leak Prevention didn't seem to do anything for me.

Link to post
Share on other sites
  • 0
iveseenenough

Same problem here- during VPN session everything freezes, browser locks everything up.  When I hard reboot, the DNS sticks with TorGuard's and won't work until I reset.  Updated to 0.3.53, but same issue persists.  Is there a fix for this?

Link to post
Share on other sites
  • 0

Same problem here- during VPN session everything freezes, browser locks everything up.  When I hard reboot, the DNS sticks with TorGuard's and won't work until I reset.  Updated to 0.3.53, but same issue persists.  Is there a fix for this?

 

 

Can we have a look via team viewer ? please submit a ticket here https://torguard.net/submitticket.php and ask for "Andy".

 

Regards

Link to post
Share on other sites
  • 0

Hi, I am currently having this exact same problem on a mac. I use my mac at both home and work. At work their firewall is set up in such a way that I cannot connect to torgurards servers. Previously I was using viscosity and have only just started using Torguards own app for a few days.

As Torguard loads and connects automatically, what I found was that when arriving at work in the morning I would have to disconnect from Torguard as I could not use the internet while it was trying to connect. This morning Torguard froze trying to connect and so I force quit the application. Now I can't access the the internet at all. It is connected to work's wifi but nothing will load.

I assume too that this is a DNS issue. I'm not sure if it still connects through Torguard as i'm still at work, but i'm assuming it will.

What file does the Torguard app change and how do I reset it on a mac manually? Through  terminal or text edit. It shouldn't be the resolve.conf on a mac. I've tried flushing the DNS cache but this hasn't worked.

 

Thanks.

Link to post
Share on other sites
  • 0

Just so i'm not wasting any supports time or for anyone else with this issue on a mac, I have fixed the problem. Basically, the resolve.conf file is generated by the system, so updating this by vi / nano I assume would be overwritten again. It was simply a case of going into system preferences -> Network. Click on the advanced button, then the DNS tab. Remove the IP's in there with the minus tab and the default IP's will be restored. 

 

I hope this helps someone.

Link to post
Share on other sites
  • 0

Just so i'm not wasting any supports time or for anyone else with this issue on a mac, I have fixed the problem. Basically, the resolve.conf file is generated by the system, so updating this by vi / nano I assume would be overwritten again. It was simply a case of going into system preferences -> Network. Click on the advanced button, then the DNS tab. Remove the IP's in there with the minus tab and the default IP's will be restored. 

 

I hope this helps someone.

 

Thanks, the latest version should do this for you automatically 0.3.53.

 

Regards

Link to post
Share on other sites
  • 0

I was having the same problem, but here's how to fix it, using Google's Public DNS Servers.

 

When you are disconnected from Torguard, go into System Preferences: Network. 

 

Hit the Advanced... Button, then click on the DNS tab.

 

You will see 2 window panes, under "DNS Servers:" click the + button and add 8.8.8.8, click + again and add 8.8.4.4, then highlight any others appearing under that pane and delete them using the - button

 

Now under the Search Domains click the + button and add .local, then highlight any others appearing under that pane and delete them using the - button

 

Click the OK button

 

Click the Apply button

 

You should be up and running again!

 

For more info on Google's Open Servers go here: https://en.wikipedia.org/wiki/Google_Public_DNS

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...