Jump to content
TorGuard
  • 0

v0.3.40 TorGuard Client for Linux

Rate this question


mobo

Question

Hello - I'm running Arch Linux 64-bit and using TorGuard Lite, v0.3.40, and I'm able to connect to the VPN, but for some reason most of the check-boxes used to select preference options in the GUI are not selectable.  Most of the boxes remain unchecked even after trying to put a check-mark in them.  Might there be some package dependency that I'm missing causing this behavior, or is there something that I can do to the config files that will give me access to all the user options?

 

The Windows version seems to be working quite well, but I'm generally on my Linux machines.

 

Thanks in advance for any help on fixing this issue.

 

Edit:  looking around online, I see some references to Qt and Torguard, but qt was not listed as a depends in the TorGuard package build for Arch, so I don't have it installed.  Could this be why the checkboxes won't allow me to select them with a checkmark?

Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

I too have this problem. Only difference is I am running Xubuntu 14.04 in a VBoX VM.

 

Originally I assumed it was a VM bug but now that someone else reported it I am also curious.

 

Cheers.

Link to post
Share on other sites
  • 0

Good day, ZuggaDubz

 

Thanks for replying so that I know that it's not just me.

 

I've gone ahead and filled out a support ticket on this issue just in case no answers are posted on the forum.  I'll reply back after I've heard something.

Link to post
Share on other sites
  • 0

Good day, again, ZuggaDubz  :)

 

I've been trading support messages back and forth with TorGuard support for a few days now, but so far they've not been able to determine what the problem is.  To make matters worse, they've now added a captcha test to the support page posting mechanism and I'm unable to get past it to complete my post with Linux, or Windows.  It appears that any further communication with the TorGuard support team for this issue or any other is non-existent for me.  I'm not sure why they would need a captcha test when a paid user is already logged into their account and trying to communicate with them.  Anyway, I'll post the details of this issue here in case a TorGuard Support person should come along and be able to offer any help.

 

TorGuard-lite:  have tried v0.3.40 and v0.3.41

Linux Distro:  Arch_x64, fully updated with Arch repos

Pkgbuild:  the Arch_x64 package-build on TorGuard downloads page

Desktop Environment:  none (have tried KDE4 with Qt5, but same results)

Window Manager:  Openbox

Widgets: Industrial (handled by Gtk2 and Gtk3)

Icon Theme:  Rox

Mouse Cursor:  Adwaita

Openbox theme:  SysCrash

 

The client works find in WinXP and Win7, but under Linux, most checkboxes on TorGuard settings window are not selectable.  Text fields do allow text input.  When looking at the settings window from a very close position, it appears that there might be a faint image of a checkmark in the checkbox, but these are not visible from normal viewing distances.

 

There is a message displayed in the terminal window that is used to start TorGuard when I open the settings window and when I try to restore the default settings:

 

"Accessing configDir(), but configDir us not set.  call hasConfigDir() first!"

 

Maybe some clue about this issue can be derived from that message.

 

I've noticed that TorGuard reside in the "/opt" folder on Arch Linux.  That folder is not used very often with Arch, so I'm wondering if there could be some kind of system PATH issue at play here, and the components in that folder are not being found?

 

Thanks to anyone that can provide any assistance.

Link to post
Share on other sites
  • 0

Hello guys, we know this checkbox problem on some styles in Linux, we are working on a general style for the App to get a consistent look across all OS's and to fix these problems, we are working on it now.

 

Regards

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...