Jump to content
TorGuard
  • 0
Ovv

Firewall block, Stealh Mode ineffective

Rate this question

Question

Ovv

My office building's public WiFi blocks VPN connections. I was never able to connect to my former VPN host when on that network. I hoped that TorGuard's Stealth mode would solve this problem for me.

 

Unfortunately, TorGuard VPN will not connect when I am connected to my office WiFi. I am using the Windows TG client. I have tried selecting the Los Angeles "Stealth" connection, both with and without the manual Stealth Proxy option. I have tried selecting other US connections, both with and without the Stealth Proxy option. Nothing works. The client just cycles between WAIT -> AUTH -> RECONNECTING endlessly.

 

(When I'm not on my office WiFi, I have no problem getting TorGuard to connect properly.)

 

I submitted a ticket to TorGuard Support, but they have been unhelpful.

 

Anyone have any ideas what I can try? Are there log files for the Windows TG client that I can examine to see if there are any clues?

Share this post


Link to post
Share on other sites

10 answers to this question

Recommended Posts

  • 0
Support

Hi

 

Just curious, with stealth proxy enabled did you try all cipher options ?

 

Regards

Share this post


Link to post
Share on other sites
  • 0
Ovv

If just curious, with stealth proxy enabled did you try all cipher options ?

 

 

 

I'm not sure what you mean about curious, but yes, I tried all cipher options (BF-CBC, AES-128-CBC, AES-256-CBC, and even NONE).

 

(When the Stealth Proxy is turned on, though, there's only one protocol available, called "Stealth Proxy," so there was no option to try UDP and TCP separately.)

Share this post


Link to post
Share on other sites
  • 0
Hercules

I have the same problem with quite a few wifi hotspots.  I've tried everything.  It just cycles endlessly just like you described.

 

My home connection it works fine.  All the time.

 

Out in public where I need it.  TorGuard is hit n miss.  Mostly miss anymore.    I've tried it on 2 laptops.  One has XP and the other has Windows 7 Professional.   Does the same thing on both computers on certain wifi spots. 

 

 

 

 

Share this post


Link to post
Share on other sites
  • 0
kofine05

Is there no solution? I would hope torguard would at least respond that they are working on it or that they have no solution.

Share this post


Link to post
Share on other sites
  • 0
19807409

Can you tell us more about which FW/Transparent proxy is used? There could be many issues, mainly on your network at work.

 

If you tried every encryption method, it means you tried port 80 as well as 443. Do you know what is not blocked, like some specific brand of VPN solution (ie. which your company uses or you to connect to other customers). If there are some, try these ports/protocols.

 

You can test it ie. by just setting socks5 proxy in your TorGuard and creataing a tunnel over ssh (ie. to your router at home or some external server) over any of those mentioned ports which are free to use. But if they block based on protocols too, then your ssh connection will not work too. If you can connect to your home/any server with ie. putty or IP provided by TorGuard (look in your account). then you can create dynamic port and config your TGclient to socks5: 127.0.0.1:YourDynamicPort.

 

Hope it helps 

Share this post


Link to post
Share on other sites
  • 0
Ramz

I have the same problem... which really sucks I tried everything even contacted the support team unsuccessful.

Share this post


Link to post
Share on other sites
  • 0
Ramz

I'm not sure what you mean about curious, but yes, I tried all cipher options (BF-CBC, AES-128-CBC, AES-256-CBC, and even NONE).

 

(When the Stealth Proxy is turned on, though, there's only one protocol available, called "Stealth Proxy," so there was no option to try UDP and TCP separately.)

Share this post


Link to post
Share on other sites
  • 0
Support

 

I'm not sure what you mean about curious, but yes, I tried all cipher options (BF-CBC, AES-128-CBC, AES-256-CBC, and even NONE).

 

(When the Stealth Proxy is turned on, though, there's only one protocol available, called "Stealth Proxy," so there was no option to try UDP and TCP separately.)

 

 

 

Hi - can i ask what country you connect from ? and what type of network your trying to connect from ?

 

Regards

Share this post


Link to post
Share on other sites
  • 0
Ramz

Hi - can i ask what country you connect from ? and what type of network your trying to connect from ?

 

Regards

 

I'm trying connect to a school network I connected to USA Miami.

Share this post


Link to post
Share on other sites
  • 0
Support

I'm trying connect to a school network I connected to USA Miami.

 

Ok - normally we find in these typos of networks they can DNS block our hostnames and so setting the Server IP Lookup to "direct IP" will bypass any DNS lookups to connect to us - if that fails make sure to try TCP on stealth, if that fails you can also try BF-CBC/TCP which uses port 443 - occasionally they restrict all DNS queries outside there network and so setting third party DNS would give you no connectivity unless you use there DNS.

 

You also have the option of using OpenConnect which uses port 22, it normally always works behind school networks.

 

Regards

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×