Jump to content
TorGuard
  • 0

vpn router speed drop

Rate this question


DFK61

Question

Hello.

 

I am running ASUS Merlin firmware version 378.55 on the N66U as a vpn client.  I have a 150/150 connection.  However when i connect to a local torguard server and do a speed test i range from 6 to 15 down the most.  Are there new torguard settings that i need to adjust for this router?    378.55

Link to post
Share on other sites

16 answers to this question

Recommended Posts

  • 0

Hello DFK61

 

Routers are much slower than desktop speeds, i believe the max (depending on encryption you use)  would be around 25/30 on this router, are you connecting to locations close by and via UDP ?

 

Regards

Link to post
Share on other sites
  • 0

I took one of my clients off of the vpn router and decided to use the desktop client, wow what a difference.  I am getting 60 down and 70 up once connected to the vpn client on the desktop, on a 150/150 connection.  

Link to post
Share on other sites
  • 0

Hey there - yeah, you should get more again, the servers have the capacity - try using Aes-128-CBC on port 80 via UDP on the router to see if this squeezes anymore for you on the router.

 

Regards

Link to post
Share on other sites
  • 0

I've been having speed issues but with an asus rt-ac87. I've been able to almost double my speed by setting the OpenVpn Client to Client2 instead of Client1. The doubling isn't much. I went from about 8 to 16 mbps. It seems like it makes the router use core2 for the vpn and core1 for the rest of your router stuff. The credit is not mine for this. I found it on another forum while researching the same issue your having.

Link to post
Share on other sites
  • 0

Do you have any of the AI Protection enabled? I've just disabled all of the AI Protection in the router and I'm using Aes-128-CBC on port 80 via UDP and I've hit 32 megabits/s.

 

 

Update:

I've just tried with BF-CBC on port 443 and I'm getting the same speeds. I hope this can help you as well.

Link to post
Share on other sites
  • 0

Do you have any of the AI Protection enabled? I've just disabled all of the AI Protection in the router and I'm using Aes-128-CBC on port 80 via UDP and I've hit 32 megabits/s.

 

 

Update:

I've just tried with BF-CBC on port 443 and I'm getting the same speeds. I hope this can help you as well.

Ben, glad to hear that, can you outline the exact steps you done with screenshots if you can, would be very helpful for users thanks

 

Regards

Link to post
Share on other sites
  • 0

Hello, all servers support Aes-128-CBC you just need to connect on port 80.

 

See our specs page inside your client area.

 

Regards

I saw Extra HMAC authorization(tls-auth) in the merlin settings, i have it set to disabled.  Do i need to adjust it to bi-directional, incoming or outgoing? if i use any of the specs settings on that page? 

 

Thanks

Link to post
Share on other sites
  • 0

I saw Extra HMAC authorization(tls-auth) in the merlin settings, i have it set to disabled.  Do i need to adjust it to bi-directional, incoming or outgoing? if i use any of the specs settings on that page? 

 

Thanks

 

Hi, no you don't need to touch that setting - you just need to change cipher and connection port.

 

Regards

  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...