Jump to content
TorGuard
  • 0

Manage Interface State did not work

Rate this question


Invisible

Question

OK, next issue...

 

I enabled the Manage Interface State and ticked my WAN connection; I have a seperate NIC for the WAN so disabling it in the event of VPN loss would be a good option for me.

 

I left my system connected to the Switzerland server and doing some downloads. Twenty minutes later I went back and checked...

 

Apparently, the VPN had been dropped although I think the TorGuard client was confused about it. I had my own IP address back according to whatismyip and my download was continuing. The TorGuard client, I think, still thought it was connected though because it still said Connected, but showed no IP addresses and it had the Disconnect button at the bottom. Confused???

 

Note: The WAN interface had not been disabled, and yet I had no VPN connection and my system was working on its real IP address.

 

I clicked the Disconnect button. Data stopped flowing.

 

I then clicked Connect, and sat while nothing happened for several minutes. Finally, I realised that the WAN interface had finally been disabled, and that TorGuard client was not re-enabling it even though i had clicked Connect. I went into my network settings and enabled the interface myself.

 

I tried the Switzerland server again, and got fed up with the client saying 'Wait' and sometimes 'tcp_connect' but without ever giving me an IP address. So, I tried London...

 

Success. I got a VPN again. However, this has raised several issues:

 

1. The TorGuard client did not recognize that the VPN had been lost. It still said Connected even though it no longer showed the VPN IP addresses and it did not disable the WAN interface.

 

2. This meant that my system was now exposed with its real IP address, even though I had configured the software to drop the WAN interface on VNP loss.

 

3. The WAN interface was only disabled when I manually clicked Disconnect in the client.

 

4. The WAN interface should have been reenabled by the client when I clicked Connect again - it should know that it had disabled the interface and needed to enable it again.

 

5. Why could I not connect back to Switzerland after five minutes of trying to... contention from other users? Not good if so.

 

If I am doing anything wrong, please let me know. As far as I can tell though, I am just trying to use the software's standard features, and they are clearly not working properly.

 

 

Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Hello there, no your doing this correctly, we have discovered a problem with the app/kill/killswitch features and these will be fixed in the next version.

 

Regards

Link to post
Share on other sites
  • 0

OK thanks, good to know it's being worked on. So is the check marks not showing (from my other post) according to my support ticket.

 

In the meantime, my windows firewall settings do the job now.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...