Jump to content
TorGuard
  • 0

Viscosity deleting connection list

Rate this question


Bit

Question

I just installed the viscosity client today and it seems to be working alright, except every time I connect to a server it tells me a few seconds later that a connections update has been downloaded and I need to disconnect if I want to install the update. As soon as I disconnect it deletes the entire list of connections and I have to reinstall the program if I want to get them back. If I don't disconnect everything works fine until I do.

I did a little searching on the forums but wasn't able to turn anything up. Anyone have any idea what could be causing this? Thanks!

Link to post
Share on other sites

22 answers to this question

Recommended Posts

  • 0

I'm having the same issues gents...

 

I've tried uninstalling the problem and performed a clean install....all to no avail...

 

I also have a ticket open but so far nothing has worked....

 

I wish the user had the option of downloading the update similar to what windows update does.

 

That way, we can continue using the current version of Torguard without interruption...

 

let's hope a fix is made available soon...

Link to post
Share on other sites
  • 0

I've been going a few rounds with support on this. Suggestions have, so far, NOT been helpful. It appears they are pushing out a connection update with NO connections.

 

What I've found is for the Windows client so you mileage may vary. My connections folder:

C:\Users\%USERNAME%\AppData\Roaming\ViscosityVPP_torguard

contains L2TP, OpenVPN, PPTP, and SSTP folders. When there's an update to push, it will also contain

L2TP Update, OpenVPN Update, etc. These folders replace the original ones.

They are pushing out these folders EMPTY.

 

Until they person in charge of pushing out these updates fixes things, it's a just a waste of time.

 

/Huggy

Link to post
Share on other sites
  • 0

 


Hi,

we released new patch that should do the trick, kindly redownload from https://torguard.net/downloads/VPNCLIENT.exe and install and let me know if that sorts it out for you.

Let us know if you have any further questions.

Regards

TorGuard Advanced Support
E: [email protected] | W: torguard.net
Add us on Twitter: http://www.twitter.com/TorGuard 

 

It worked for me. Hope this works out for you guys.

Link to post
Share on other sites
  • 0

Looks like that worked for me! Thanks, Will.

 

As a side note, I've also found that its useful to duplicate the connections you use so that they can be edited. By default it looks like viscosity has the "send all traffic over vpn connection" box unticked for some reason, which results in dns leaks and who knows what else. So I checked that box as well as set the dns mode to "Full DNS". I have no idea why its set like that but you can test it at https://dnsleaktest.com/

Link to post
Share on other sites
  • 0

Looks like that worked for me! Thanks, Will. As a side note, I've also found that its useful to duplicate the connections you use so that they can be edited. By default it looks like viscosity has the "send all traffic over vpn connection" box unticked for some reason, which results in dns leaks and who knows what else. So I checked that box as well as set the dns mode to "Full DNS". I have no idea why its set like that but you can test it at https://dnsleaktest.com/

 

Are you using the Mac or Windows version?

 

I don't have the "Full DNS" or "send all traffic over vpn connection" options within Viscosity. I am on Windows 10.

Link to post
Share on other sites
  • 0

I'm on Windows 7. You have to change those settings within each individual connection. It won't let you edit the connection until you duplicate it though, just select the connection you want and press the little gear button next to the edit button on the bottom right to duplicate it. Then you can select the new connection and edit its settings.

  • Like 1
Link to post
Share on other sites
  • 0

Thanks Bit et all for the great tips...

 

I have duplicated my connections based upon the working fix and all seems to be running smoothly again...

 

Additionally, I like to use VPN Pro check as an added measure to reduce the chances of DNS leaks as well as to automatically disconnect my bittorrent program should Torguard time out after 110 minutes or so..

 

If interested the file can be downloaded from www.kat.cr as follows:

 

http://kat.cr/vpncheck-pro-1-5-3-8-final-incl-keygen-scenedl-pimprg-t7430376.html

 

good luck to all and happy anonymous surfing....

Link to post
Share on other sites
  • 0

Thanks Bit et all for the great tips...

 

I have duplicated my connections based upon the working fix and all seems to be running smoothly again...

 

Additionally, I like to use VPN Pro check as an added measure to reduce the chances of DNS leaks as well as to automatically disconnect my bittorrent program should Torguard time out after 110 minutes or so..

 

If interested the file can be downloaded from www.kat.cr as follows:

 

http://kat.cr/vpncheck-pro-1-5-3-8-final-incl-keygen-scenedl-pimprg-t7430376.html

 

good luck to all and happy anonymous surfing....

 

That software is very finicky and does not always work. I've tried it before.

Link to post
Share on other sites
  • 0

That software is very finicky and does not always work. I've tried it before.

 

hmmmm...  It works find for me...

 

within the "config" menu, my "applications" setttings is as follows:

 

  • Filename - Azureus
  • Filepath - .c:\program files \ etc..etc...etc..
  • Close - Yes
  • Autorun - No
  • Close (box is check)

So whenever torguard closes and Azureus is running, VPN Check Pro will automatically shutdown Azureus...

 

Sorry to hear that the program was not working for you...

Link to post
Share on other sites
  • 0

hmmmm...  It works find for me...

 

within the "config" menu, my "applications" setttings is as follows:

 

  • Filename - Azureus
  • Filepath - .c:\program files \ etc..etc...etc..
  • Close - Yes
  • Autorun - No
  • Close (box is check)

So whenever torguard closes and Azureus is running, VPN Check Pro will automatically shutdown Azureus...

 

Sorry to hear that the program was not working for you...

 

I was referring to their DNS leak feature. It occasionally leaks.

Link to post
Share on other sites
  • 0
DrMorbius

Just got another notice that the VPN Connection List was to be updated, either right then via 'YES' or when the connection disconnected. I disocnnected the VPN session and the Connection list was erased (again).

 

I tried re-installing the 'patch' (https://torguard.net...s/VPNCLIENT.exe ) released yesterday and this didn't work either, the connection list was still blank.

 

I'm submitting a ticket and see what happens.

 

 

  • Like 1
Link to post
Share on other sites
  • 0
DrMorbius

Alright I posted a ticket and got a reply.

 

If you downloaded the 'patch' from the posted link in @Will yesterday, you need to redownload it today. I re-ran the patch downloaded from yesterday (8/4) which does not offer the option noted by @JJJJ of Append / Overwirte / Ignore.  If you have edited connections, inserted your own, etc, select append, if you want to clean the list choose overwirte.

 

On my Windows 8.1 Pro PC the installation process ran without issue. On my Windows 7 PC the installation ran into issues replacing files in use. These files appeared related to the service / driver / adapter of Viscosity. I selected, ignore for the files in use and the installation finished and offered the VPN List update options. I chose to 'ignore' since I figured the installer from yesterday ran without problem there was little chance of a change to those files overnight. The VPN connection appears to be running OK and passes the leak dectectors. I have reported the Win 7 Install issues to Support.

 

I also hope the update process gets fixed.

  • Like 2
Link to post
Share on other sites
  • 0
Support

Sorry for the updates again guys, we have fixed the issue, simply re-download Viscosity using this link: torguard.net/downloads/VPNCLIENT.exe

 

Install over the top of your install, the configs are now bundled with the installer rather than depending on an external update, which seems to be causing the problems.

 

We are working with sparklabs to see what we can do for smoother updates in future.

 

Regards

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...