Jump to content
TorGuard
  • 0
Sign in to follow this  
52748_1511348126

Hong Kong DPI Fix for Viscosity

Rate this question

Question

52748_1511348126

Hello, I am currently thinking of extending Torguard, but there still hasn't been a DPI fix for Viscosity for the Hong Kong Server. Are you planning to provide one? And if so, do you have an ETA (roughly)?

 

Thanks

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0
Support

Hey Ellok

 

This should already be fixed, have you received any config updates recently ?

 

Have you tried our new TG Lite app ? it contains the fixes for HK.

 

Regards

Share this post


Link to post
Share on other sites
  • 0
52748_1511348126

Hello,

 

thanks for the reply. TG Lite is working fine, but I prefer Viscosity for the additional options and the unobtrusive menu bar item.

 

In the downloads section Viscosity doesn't seem to have been updated since May 2014, so I didn't bother reinstalling it.

I did now (after deleting all Preferences+Application Support), but nothing has changed. I can connect to any other server that I have tried, only Hong Kong does't work. Below you can find the log

 

Aug 16 14:38:52 Viscosity Mac 1.0 (1219)

Aug 16 14:38:52 Viscosity OpenVPN Engine Started

Aug 16 14:38:52 Running on Mac OS X 10.9.4

Aug 16 14:38:52 ---------

Aug 16 14:38:52 State changed to Connecting

Aug 16 14:38:52 Checking reachability status of connection...

Aug 16 14:38:52 Connection is reachable. Starting connection attempt.

Aug 16 14:38:54 OpenVPN 2.3.4 i386-apple-darwin [sSL (OpenSSL)] [LZO] [PKCS11] [MH] [iPv6] built on Jun 6 2014

Aug 16 14:38:55 WARNING: No server certificate verification method has been enabled. See http://openvpn.net/howto.html#mitm for more info.

Aug 16 14:38:55 Cannot load CA certificate file ca.crt (no entries were read): error:0906D066:PEM routines:PEM_read_bio:bad end line

Aug 16 14:38:55 State changed to Disconnected

Aug 16 14:38:56 Viscosity Mac 1.0 (1219)

Aug 16 14:38:56 Viscosity OpenVPN Engine Started

Aug 16 14:38:56 Running on Mac OS X 10.9.4

 

Is it or will it be possible in the future to use Viscosity for all servers including Hong Kong?

 

Thanks.

 

//Update:

It seems to be a problem with the certificate. I tried to use the imported Hong Kong connection from "OpenVPN config files (Manual Install)" instead, but that didn't work at all (error for unknown option scramble....).

 

But now I just replaced the invalid ca.cert with the hkca.cert from the "OpenVPN config files (Manual Install)" and now everything is working with Viscosity. Is this the solution? Maybe you could update the Viscosity download then. Thanks :-)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...