Jump to content
TorGuard
  • 0

port forward from router not working

Rate this question


oggie

Question

ok. I'll do my best to explain what I'm seeing.

 

I have a linux box that has the open vpn client running. I have an asus ac66u router that does a dyndns as well.

 

I also have port forwarding set up on the vpn so I can connect to my server remotely through the vpn. It also works fine.

 

What I then did was set up the router to connect to dyndns and forward a separate port to the linux box (192.168.1.100). I did this so that if I wanted to, I could also connect to the server without going through the vpn. For maintenance, or restart the vpn if it goes down etc.

 

But for some reason, the router isn't forwarding it to the server. I assume it's the router since I can connect to 192.168.1.100 when I'm home and the vpn is up.

 

Thoughts? Is it the router? There's nothing I need to do to the routing on the server I assume...

 

Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

There's no firewall set up on the ubuntu box. The port forwarding from the router works the moment I turn off the vpn on ubuntu. It just stops working the moment I enable the VPN.

Link to post
Share on other sites
  • 0

Old question, but no final answer, so I thought I would put in my 2 cents in case someone else finds this. Most likely your inbound connection was making it to your Linux box via your WAN IP (Non VPN), however, since it is connected to the vpn via 1.100, any outgoing packets are going back out through the VPN, not completing the connection. There are supposedly ways to get around this by using iptables and routes (I have had 0 luck in situations like this) or add another NIC (or virtual NIC), assign it a different IP and pull it off the VPN using Policy Based Routing. 1.100 stays on the VPN and 1.101 would stay on the ISP WAN. I know thats not ideal.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...