Jump to content
TorGuard
  • 1

4.8.5 Windows 10 is using over 20% of my CPU even when not connected (I5 7600K)

Rate this question


jcspamcan
 Share

Question

4.8.5 Windows 10 is using over 20% of my CPU even when not connected (I5 7600K). Connecting with Wireguard does not seem to increase CPU load although 20-22% seems like way too much CPU power considering I'm using an I5 7600K. I upgraded to 4.8.5 because 4.8.2 seemed had the same issue. Is this the way it is the application should be interacting with my CPU ?

Link to comment
Share on other sites

7 answers to this question

Recommended Posts

  • 0
3 hours ago, jcspamcan said:

4.8.5 Windows 10 is using over 20% of my CPU even when not connected (I5 7600K). Connecting with Wireguard does not seem to increase CPU load although 20-22% seems like way too much CPU power considering I'm using an I5 7600K. I upgraded to 4.8.5 because 4.8.2 seemed had the same issue. Is this the way it is the application should be interacting with my CPU ?


I just tried Testing and It barely seems to be using any Resources at All on my computer > While Connected* in Task Manager it says Torguard is only using 0.1% and Wireguard says it is using 0%.

I do admit 20% seems slightly high apposed to the 0.1% mine uses, you say it uses 20% even when Not connected?? so if that is the case then protocol shouldn't have too much to do with it if that is what it is using when your Not even Connected. Maybe try changing the theme? I use the classic theme* it's possible the modern theme may use more resources as i think it utilizes OpenGL but i could be wrong but you can try changing theme.

I am using Windows 10 64bit* with 16GB Ram and Ryzen 3600XT CPU.

 

Screenshot_14.jpg

  • Thanks 1
Link to comment
Share on other sites

  • 0

Changing to classic theme fixed it. Torguard is now using less than 1% CPU. Thanks. Although I don't need the modern theme, the 20% CPU usage using modern theme sure seems like a bug.

Link to comment
Share on other sites

  • 0
34 minutes ago, jcspamcan said:

Changing to classic theme fixed it. Torguard is now using less than 1% CPU. Thanks. Although I don't need the modern theme, the 20% CPU usage using modern theme sure seems like a bug.


It Does slightly seem high however you Noted you use a i5 7600k CPU which i believe K Models have built in graphics Assuming your using the IGPU  "Built in Graphics" that would tie in with the OpenGL which i believe is used in the Modern theme which would Definitely Put more stress on the CPU Because it would be Utilizing the OpenGL in the Intel HD Graphics 630.

If you are not using the built in graphics and you are using a dedicated graphics card then it would be more curious as it should be drawing the OpenGL from that but even in that case if you have both a dedicated card and IGPU both sometimes programs will select one or the other for some programs if they are being Utilized for Graphics. Usually in the settings somewhere you can choose which graphics processing unit is to be used for that specific program or Globally* and you can change it to a specific one if you have both*, which would take strain off the CPU if it was utilizing the OpenGL in the IGPU.

Link to comment
Share on other sites

  • 0

The problem with the modern theme using 20% CPU is the only quirky behavior this computer has had. I have a 1060 Ti 6GB, and can play Open GL games and any modern game. The problem would seem to be with the Torguard app. I'll wait for an update and next time I won't install Open GL and see if that helps.

 

Link to comment
Share on other sites

  • 0
3 hours ago, jcspamcan said:

The problem with the modern theme using 20% CPU is the only quirky behavior this computer has had. I have a 1060 Ti 6GB, and can play Open GL games and any modern game. The problem would seem to be with the Torguard app. I'll wait for an update and next time I won't install Open GL and see if that helps.

 


What you are experiencing Might be Normal you Mentioned that it is Drawing 20% from the CPU when using the Modern Theme But if you change the theme to Classic it uses Less CPU Resources that would Imply that it is Drawing the OpenGL From your Intel HD Graphics 630 inside your Processor , As I mentioned Above if you have Both IGPU and Dedicated Graphics card Both* Sometimes Windows will Assign Either the IGPU or Dedicated GPU if you have both to run some programs automatically using one or the other GPU or IGPU This is often A setting within Windows which can be Manually Configured.

The Intel HD 630 IGPU is not very powerful So when it is Being Utilized for both CPU and Graphics* Combined Drawing 20% from it is likely Normal Because it Does Not Have Powerful Graphics Inside it. You Mentioned you Have a Dedicated Graphics Card as well - Sometimes you can go into your Windows Settings and Choose which Graphics Processing Unit is to be used for Specific Programs and stuff like that But of course that gets Somewhat Technical Maybe google it if you wish to Attempt it. There is nothing Necessarily Wrong with it Drawing the OpenGL from the IGPU Your CPU running at 20% Should be Completely Safe, If you don't like it running at 20% then possibly using the Classic Theme May be the easiest Workaround.

Link to comment
Share on other sites

  • 0

I just wanted to report I had the exact same issue with high cpu usage from the torguard app, 50% in my case. The system is an Intel 3570k with GTX 960 video card, Windows 10 with latest updates, latest torguard app using Wireguard. I searched the forum and found this thread, after changing the theme from modern to classic the cpu usage went down to less than 1%, so yep that's the fix so thanks for the advice.

BTW as an experiment I tried disabling the onboard integrated graphics of the cpu in the BIOS and then using the modern theme but that still resulted in high cpu usage.

Link to comment
Share on other sites

  • 0
2 hours ago, anonuser said:

I just wanted to report I had the exact same issue with high cpu usage from the torguard app, 50% in my case. The system is an Intel 3570k with GTX 960 video card, Windows 10 with latest updates, latest torguard app using Wireguard. I searched the forum and found this thread, after changing the theme from modern to classic the cpu usage went down to less than 1%, so yep that's the fix so thanks for the advice.

BTW as an experiment I tried disabling the onboard integrated graphics of the cpu in the BIOS and then using the modern theme but that still resulted in high cpu usage.


Hey @anonuser

It's Similar Results for me as well However I Don't Have Built in Graphics at all ((Ryzen 3600XT)) and the "Modern" Theme Does Not Really Effect My CPU. The CPU usage is basically Exactly the same with either Modern or Classic Theme, However* Using the Modern Theme Increases my Dedicated Graphics Card usage by 7-10% it fluctuates a bit Even When Not Connected I Believe that is Normal Because Whether it is Connected or Disconnected Either way the Program Itself is Utilizing System Resources Such as But Maybe Not Limited to "OpenGL".

I don't Normally use the Modern Theme Because I Prefer the Design of the Classic Theme Just Personal Preference Though - I am not sure why Your System Still Sounds Like it's Drawing Extra Resources From The CPU Even when you Have IGPU Disabled in Bios Because it Doesn't seem to Increase CPU Usage on my system at all But I don't even Have Built in Graphics so I would Guess that it's Possibly Still Drawing OpenGL or something from the Intel CPU/IGPU But i am not sure.

I Believe the Results Are Different For Everyone Depending on System Specifications.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...