Jump to content
TorGuard
  • 0

Proxies down?

Rate this question


Room101
 Share

Question

I haven't been able to connect to an anonymous proxy now in over 8 hours.  No configuration changed on my system.  I even got desperate enough to install the TorGuard extension for Chrome; it doesn't connect (I can log in, but connecting gives a "no IP".).   I can't use a specific host, such as us-ny.torguard.com, nor can I use the generic proxy.torguard.org.

 

I don't use (or need) the VPN services, and I assume my low end account doesn't have access to those. Is there anything I can do to figure out the issue with the anonymous proxies? Torguard doesn't seem to have a tool for this, and I hate opening a ticket if it's somehow on my end.

Link to comment
Share on other sites

Recommended Posts

  • 0
10 minutes ago, Igo said:

Hello, I have the same problem:

curl --proxy https://XXX:[email protected]:7070 https://api.ipify.org?format=json
curl: (56) Recv failure: Connection reset by peer

 

More details:
 

 curl -vv --proxy https://XXX:[email protected]:489 https://api.ipify.org?format=json
* Rebuilt URL to: https://api.ipify.org/?format=json
*   Trying 146.70.51.18...
* Connected to us-fl.secureconnect.me (146.70.51.18) port 489 (#0)
* Establish HTTP proxy tunnel to api.ipify.org:443
* Proxy auth using Basic with user 'XXXX'
> CONNECT api.ipify.org:443 HTTP/1.1
> Host: api.ipify.org:443
> Proxy-Authorization: Basic XXXX
> User-Agent: curl/7.47.0
> Proxy-Connection: Keep-Alive
> 
* Recv failure: Connection reset by peer
* Received HTTP code 0 from proxy after CONNECT
* Closing connection 0
curl: (56) Recv failure: Connection reset by peer

I've also tested other ports (7070, 23,993...) 

 

@Support please help :) It seems like a problem with your authorization.

Something I can actually help with...

Add

--ssl

 to your commandline.

curl --ssl --proxy https://XXX:[email protected]:7070 https://api.ipify.org?format=json 

And you can verify http via:

curl --proxy https://XXX:[email protected]:7070 http://api.ipify.org?format=json 

 

Sperging:

I've actually had to beat my head against this issue for multiple hours, so I'm pretty annoyed myself. I had not a single issue with Opera and my extension of choice, for years. 

Since this wonderful change, I've had to wade through trying to make FoxyProxy work (it does NOT, using the Chrome extension (which all work in Opera, but not the official Torguard extension, which has an inane check to make sure it's actually Chrome, that bypasses Opera's fake "Chrome compatible" flag. Jerks.)) and finally finding "Simple Proxy" works with https. (To use VPN.s, one must use the PAC file I noted earlier.  And one can't simply load a PAC file into FoxyProxy.)

 

Link to comment
Share on other sites

  • 0
8 minutes ago, Room101 said:

Something I can actually help with...

Add

--ssl

 to your commandline.

curl --ssl --proxy https://XXX:[email protected]:7070 https://api.ipify.org?format=json 

And you can verify http via:

curl --ssl --proxy https://XXX:[email protected]:7070 http://api.ipify.org?format=json 

 

Sperging:

I've actually had to beat my head against this issue for multiple hours, so I'm pretty annoyed myself. I had not a single issue with Opera and my extension of choice, for years. 

Since this wonderful change, I've had to wade through trying to make FoxyProxy work (it does NOT, using the Chrome extension (which all work in Opera, but not the official Torguard extension, which has an inane check to make sure it's actually Chrome, that bypasses Opera's fake "Chrome compatible" flag. Jerks.)) and finally finding "Simple Proxy" works with https. (To use VPN.s, one must use the PAC file I noted earlier.  And one can't simply load a PAC file into FoxyProxy.)

 

Nope:
 

curl --ssl --proxy https://XXX:[email protected]:7070 https://api.ipify.org?format=json
curl: (56) Recv failure: Connection reset by peer

 

for proxy.secureconnectt.me:6060

 

curl --ssl --proxy https://XXX:[email protected]:6060 https://api.ipify.org?format=json
{"ip":"88.202.XX.AA"}

 

Link to comment
Share on other sites

  • 0
8 minutes ago, Igo said:

Nope:
 

curl --ssl --proxy https://XXX:[email protected]:7070 https://api.ipify.org?format=json
curl: (56) Recv failure: Connection reset by peer

There's something else amiss here.  I'll note that I get that if I leave off the https: for the proxy... 

 

$ curl -v --ssl --proxy https://XXX:[email protected]:7070 https://api.ipify.org?format=json
* Expire in 0 ms for 6 (transfer 0x555d357220c0)
* Expire in 1 ms for 1 (transfer 0x555d357220c0)
* Expire in 0 ms for 1 (transfer 0x555d357220c0)
* Expire in 1 ms for 1 (transfer 0x555d357220c0)
* Expire in 0 ms for 1 (transfer 0x555d357220c0)
* Expire in 0 ms for 1 (transfer 0x555d357220c0)
* Expire in 2 ms for 1 (transfer 0x555d357220c0)
* Expire in 0 ms for 1 (transfer 0x555d357220c0)
* Expire in 0 ms for 1 (transfer 0x555d357220c0)
* Expire in 2 ms for 1 (transfer 0x555d357220c0)
* Expire in 0 ms for 1 (transfer 0x555d357220c0)
* Expire in 0 ms for 1 (transfer 0x555d357220c0)
* Expire in 2 ms for 1 (transfer 0x555d357220c0)
* Expire in 0 ms for 1 (transfer 0x555d357220c0)
* Expire in 0 ms for 1 (transfer 0x555d357220c0)
* Expire in 2 ms for 1 (transfer 0x555d357220c0)
* Expire in 0 ms for 1 (transfer 0x555d357220c0)
* Expire in 0 ms for 1 (transfer 0x555d357220c0)
* Expire in 2 ms for 1 (transfer 0x555d357220c0)
* Expire in 0 ms for 1 (transfer 0x555d357220c0)
* Expire in 0 ms for 1 (transfer 0x555d357220c0)
* Expire in 2 ms for 1 (transfer 0x555d357220c0)
* Expire in 0 ms for 1 (transfer 0x555d357220c0)
* Expire in 1 ms for 1 (transfer 0x555d357220c0)
* Expire in 2 ms for 1 (transfer 0x555d357220c0)
* Expire in 1 ms for 1 (transfer 0x555d357220c0)
* Expire in 1 ms for 1 (transfer 0x555d357220c0)
* Expire in 2 ms for 1 (transfer 0x555d357220c0)
* Expire in 1 ms for 1 (transfer 0x555d357220c0)
* Expire in 1 ms for 1 (transfer 0x555d357220c0)
* Expire in 2 ms for 1 (transfer 0x555d357220c0)
* Expire in 1 ms for 1 (transfer 0x555d357220c0)
* Expire in 1 ms for 1 (transfer 0x555d357220c0)
* Expire in 2 ms for 1 (transfer 0x555d357220c0)
*   Trying 146.70.51.50...
* TCP_NODELAY set
* Expire in 149996 ms for 3 (transfer 0x555d357220c0)
* Expire in 200 ms for 4 (transfer 0x555d357220c0)
* Connected to us-fl.secureconnect.me (146.70.51.50) port 7070 (#0)
* ALPN, offering http/1.1
* successfully set certificate verify locations:
*   CAfile: /etc/ssl/certs/ca-certificates.crt
  CApath: none
* TLSv1.2 (OUT), TLS handshake, Client hello (1):
* TLSv1.2 (IN), TLS handshake, Server hello (2):
* TLSv1.2 (IN), TLS handshake, Certificate (11):
* TLSv1.2 (IN), TLS handshake, Server key exchange (12):
* TLSv1.2 (IN), TLS handshake, Server finished (14):
* TLSv1.2 (OUT), TLS handshake, Client key exchange (16):
* TLSv1.2 (OUT), TLS change cipher, Change cipher spec (1):
* TLSv1.2 (OUT), TLS handshake, Finished (20):
* TLSv1.2 (IN), TLS handshake, Finished (20):
* SSL connection using TLSv1.2 / DHE-RSA-AES256-GCM-SHA384
* ALPN, server did not agree to a protocol
* Proxy certificate:
*  subject: CN=*.secureconnect.me
*  start date: Aug 28 18:13:05 2021 GMT
*  expire date: Nov 26 18:13:04 2021 GMT
*  subjectAltName: host "us-fl.secureconnect.me" matched cert's "*.secureconnect.me"
*  issuer: C=US; O=Let's Encrypt; CN=R3
*  SSL certificate verify ok.
* allocate connect buffer!
* Establish HTTP proxy tunnel to api.ipify.org:443
* Proxy auth using Basic with user 'XXX'
> CONNECT api.ipify.org:443 HTTP/1.1
> Host: api.ipify.org:443
> Proxy-Authorization: Basic YYY
> User-Agent: curl/7.64.0
> Proxy-Connection: Keep-Alive
>
< HTTP/1.1 200 Connection established
<
* Proxy replied 200 to CONNECT request
* CONNECT phase completed!
* ALPN, offering http/1.1
* successfully set certificate verify locations:
*   CAfile: /etc/ssl/certs/ca-certificates.crt
  CApath: none
* TLSv1.2 (OUT), TLS handshake, Client hello (1):
* CONNECT phase completed!
* CONNECT phase completed!
* TLSv1.2 (IN), TLS handshake, Server hello (2):
* TLSv1.2 (IN), TLS handshake, Certificate (11):
* TLSv1.2 (IN), TLS handshake, Server key exchange (12):
* TLSv1.2 (IN), TLS handshake, Server finished (14):
* TLSv1.2 (OUT), TLS handshake, Client key exchange (16):
* TLSv1.2 (OUT), TLS change cipher, Change cipher spec (1):
* TLSv1.2 (OUT), TLS handshake, Finished (20):
* TLSv1.2 (IN), TLS handshake, Finished (20):
* SSL connection using TLSv1.2 / ECDHE-RSA-AES128-GCM-SHA256
* ALPN, server did not agree to a protocol
* Server certificate:
*  subject: CN=*.ipify.org
*  start date: Jan 19 00:00:00 2021 GMT
*  expire date: Feb 19 23:59:59 2022 GMT
*  subjectAltName: host "api.ipify.org" matched cert's "*.ipify.org"
*  issuer: C=GB; ST=Greater Manchester; L=Salford; O=Sectigo Limited; CN=Sectigo RSA Domain Validation Secure Server CA
*  SSL certificate verify ok.
> GET /?format=json HTTP/1.1
> Host: api.ipify.org
> User-Agent: curl/7.64.0
> Accept: */*
>
< HTTP/1.1 200 OK
< Server: Cowboy
< Connection: keep-alive
< Content-Type: application/json
< Vary: Origin
< Date: Wed, 20 Oct 2021 08:18:07 GMT
< Content-Length: 21
< Via: 1.1 vegur
<
* Connection #0 to host us-fl.secureconnect.me left intact
{"ip":"146.70.51.50"}
$

 

Link to comment
Share on other sites

  • 0

For me 7070 port doesn't work:
 

curl -v --ssl --proxy https://XXX:[email protected]:7070 https://api.ipify.org?format=json
* Rebuilt URL to: https://api.ipify.org/?format=json
*   Trying 68.71.244.66...
* connect to 68.71.244.66 port 7070 failed: Connection refused
*   Trying 37.120.141.114...
* connect to 37.120.141.114 port 7070 failed: Connection refused
*   Trying 194.59.250.226...
* connect to 194.59.250.226 port 7070 failed: Connection refused
*   Trying 37.120.141.122...
* connect to 37.120.141.122 port 7070 failed: Connection refused
*   Trying 185.212.171.118...
* connect to 185.212.171.118 port 7070 failed: Connection refused
*   Trying 37.120.244.206...
* connect to 37.120.244.206 port 7070 failed: Connection refused
*   Trying 88.202.177.239...
* Connected to proxy.secureconnect.me (88.202.177.239) port 7070 (#0)
* Establish HTTP proxy tunnel to api.ipify.org:443
* Proxy auth using Basic with user 'YYYYYYYYYYYYYY'
> CONNECT api.ipify.org:443 HTTP/1.1
> Host: api.ipify.org:443
> Proxy-Authorization: Basic XXXXXXXXXXXXXXX=
> User-Agent: curl/7.47.0
> Proxy-Connection: Keep-Alive
> 
* Recv failure: Connection reset by peer
* Received HTTP code 0 from proxy after CONNECT
* Closing connection 0
curl: (56) Recv failure: Connection reset by peer

The proxy find a free IP for me, but this IP rejected the connect...

Link to comment
Share on other sites

  • 0

Bogus; what an all around headache.  Failing with the same valid credentials, and same command, that's a pretty neat trick they've got. :(

 

To anyone else who is as much of an idiot as me though, thanks to Igo, I realized that leaving the urls naked is why everything failed in extensions trying to use one for all. Make sure you add the 'https"

    \PortableOpera\launcher.exe --proxy-server="us-fl.secureconnect.me:7070" <-- Fail sandwich. (Presumably, :6060 would have worked here, before.)

    \PortableOpera\launcher.exe --proxy-server="https://us-fl.secureconnect.me:7070" <--  Works.

This might also work for mIRC, etc. 

 

Link to comment
Share on other sites

  • 0

Nothing I tried work, none of the new ports, not the secureconnect.me servers. W10 proxy Internet Properties/Connections/LAN settings/Use a proxy for your LAN/Advanced: HTTP now empty and HTTPS secureconnect.me address with 7070 port = no connection.

Not happy. What can I do?

proxies.PNG

Link to comment
Share on other sites

  • 0
Hi,
Yes, this has been very frustrating for me.
I have been a customer since around 2013.
I have been trying to fault find this issue and changed various settings on my computer.
This has caused me some grief.
 
I raised a held desk ticket when I was getting no where.
I even asked "Has anything changed at your end ?"
Deathly silence on this very specific question.
 
If a change is coming why not tell everyone in advance?
Even a brief warning would be better than NO WARNING !!
 
In any case, I can confirm that the following configuration works:
-- Windows 10 PC
-- Firefox
-- Foxy Proxy extension (using the following):
---- Any proxy server of the form "xx.secureconnect.me"
---- Proxy Type= HTTPS/SSL
---- Port=7070
---- Username and Password = unchanged.
 
Best of luck to everyone.
Link to comment
Share on other sites

  • 0
19 hours ago, gp3000 said:

 

I'm using JD in the same manner. You just have to switch to https, use secureconnect.me and a different port and they will work.

Just make a list of all the proxies like https://username:[email protected]:592 click on import in JD paste them and you should be good.

 

That works. Thanks for the quick help.

Link to comment
Share on other sites

  • 0

After wasting a lot of time trying to solve why the Firefox extension didn't appear to be working, I found this thread.

I have managed to get Foxy Proxy method working but despite trying different ports certain websites do not load or do so very slowly. No such problem with Windscribe and Nord.

Looking to sign up for a couple of years but this and lack of information provided to subscribers is huge red flag for me.

Link to comment
Share on other sites

  • 0
7 hours ago, LittleDude said:

After wasting a lot of time trying to solve why the Firefox extension didn't appear to be working, I found this thread.

I have managed to get Foxy Proxy method working but despite trying different ports certain websites do not load or do so very slowly. No such problem with Windscribe and Nord.

Looking to sign up for a couple of years but this and lack of information provided to subscribers is huge red flag for me.

 

The plain HTTP proxies are back online - can you send a screenshot of your foxy proxy settings?

Link to comment
Share on other sites

  • 0
On 10/23/2021 at 5:42 PM, LittleDude said:

Tried different ports listed earlier in this thread also.

Foxy Proxy.png

 

Can you retry these now please?

Thanks

Link to comment
Share on other sites

  • 0

mine also keep failing, this is very inconvenience and now looking it seems its been leaking my IP anyway so its pointless to use anymore 

Link to comment
Share on other sites

  • 0
On 10/20/2021 at 10:12 AM, Room101 said:

Something I can actually help with...

Add

--ssl

 to your commandline.

curl --ssl --proxy https://XXX:[email protected]:7070 https://api.ipify.org?format=json 

And you can verify http via:

curl --proxy https://XXX:[email protected]:7070 http://api.ipify.org?format=json 

 

Sperging:

I've actually had to beat my head against this issue for multiple hours, so I'm pretty annoyed myself. I had not a single issue with Opera and my extension of choice, for years. 

Since this wonderful change, I've had to wade through trying to make FoxyProxy work (it does NOT, using the Chrome extension (which all work in Opera, but not the official Torguard extension, which has an inane check to make sure it's actually Chrome, that bypasses Opera's fake "Chrome compatible" flag. Jerks.)) and finally finding "Simple Proxy" works with https. (To use VPN.s, one must use the PAC file I noted earlier.  And one can't simply load a PAC file into FoxyProxy.)

 

Change the port to 6060. That worked for me with Firefox version 94.0.2

proxy.PNG

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...