Jump to content
TorGuard
  • 0

Linksys WRT3200ACM-EU

Rate this question


Nuno
 Share

Question

Hello, 

I need some help and will try to the problem to see if can anyone help me.

I have 2 routers, 1 Asus RT-AC68U and another Linksys WRT3200ACM-EU.

On the  Asus RT-AC68U with DD_WRT and im using wireguard with the setup explained on site and it's working with no issues.

When im trying the same setup on Linksys WRT3200ACM-EU with DD_WRT also dont work, is there any adicional config for this type of router? Can someone help me please? 

Thanks in advance and best regards to all comunnity

Link to comment
Share on other sites

5 answers to this question

Recommended Posts

  • 0
2 hours ago, Nuno said:

I need some help and will try to the problem to see if can anyone help me.

Hello, not a lot can be helped if you do not specify exactly what it is about. What exactly is not working if you have exactly the same config?

On openwrt everything works, on every device and is quite simple to setup in webgui (luci).

Openwrt page for Asus RT-AC68U and here for Linksys WRT3200ACM-EU (which you say does not work with ddwrt).Latest openwrt release 21.02.0 uses kernel 5 and for wireguard you only need to install luci-app-wireguard from Software tab or over terminal:

opkg update && opkg install luci-app-wireguard

If you get kmod error, you can ignore it, it installed

From there on, go to networks and create new interface where you can choose Wireguard, then copy&paste values from your existing wireguard config, save&apply then reboot.

 

Link to comment
Share on other sites

  • 0
13 minutes ago, 19807409 said:

Hello, not a lot can be helped if you do not specify exactly what it is about. What exactly is not working if you have exactly the same config?

On openwrt everything works, on every device and is quite simple to setup in webgui (luci).

Openwrt page for Asus RT-AC68U and here for Linksys WRT3200ACM-EU (which you say does not work with ddwrt).Latest openwrt release 21.02.0 uses kernel 5 and for wireguard you only need to install luci-app-wireguard from Software tab or over terminal:

opkg update && opkg install luci-app-wireguard

If you get kmod error, you can ignore it, it installed

From there on, go to networks and create new interface where you can choose Wireguard, then copy&paste values from your existing wireguard config, save&apply then reboot.

 

hi,
i only use one router each time, dont use both at same time...
i setup the asus, connect with wireguard with the support page guides and it work good on any server...
i disconnect the asus and connect the Linksys WRT3200ACM-EU with the same setup and simply dont connect to any server, even check the status on torguard page suggested it says "unprotected" and my location and contract isp dont change...
dont know what can be...

I preffer to use DD_WRT , is more usefriendly with a gui more easy to use and using wireguard and more stable...

Link to comment
Share on other sites

  • 0
8 hours ago, Nuno said:

i only use one router each time, dont use both at same time...

1. You can use them both at the same, make sure that you use different private keys on both, then you can connect from both at the same time too if you wish to the same address. If it is port forwarding ip, then port forward will work only for one connection to that server

8 hours ago, Nuno said:

i setup the asus, connect with wireguard with the support page guides and it work good on any server...

That means config and router setup seem to be ok.

8 hours ago, Nuno said:

i disconnect the asus and connect the Linksys WRT3200ACM-EU with the same setup and simply dont connect to any server, even check the status on torguard page suggested it says "unprotected" and my location and contract isp dont change..

Here it seems that either your router setup or wireguard config for your router setup or ddwrt firmware for your device. If you exclude the config as it works on asus, then you should check your router setup (something like factory restore then retry, just backup your current settings before you restore to factory).

8 hours ago, Nuno said:

I preffer to use DD_WRT , is more usefriendly with a gui more easy to use and using wireguard and more stable...

:huh: guess it is not that stable if same setup on two routers does not work, the same goes about user friendly gui which ddwrt isnt ;), once you switch to openwrt, you will probably never go back to dd-wrt.

I do not know how to help you if you did not post your router config/logs as well as you did not post your wireguard configs, however I can help with openwrt.

Openwrt stable versions include a gui, in openwrt in is called luci, therefore all gui applications are luci-app-*.

I do not know which kernel version is used on your ddwrt image, openwrt's latest stable release includes v5.4.143, which does run nice with wireguard.

 

More screenshots:

You do not have to install wireguard over ssh,. you can do it in like you call it GUI, Click on "System -> Software" then click "Update lists", then in filter luci-app-wirguard, then click on "Install", that is it.

image.png

For wireguard:
1. go to interfaces and create new wireguard interface 

image.png

2. Paste your settings from wireguard config and add your wireguard interface to WAN firewall zone

image.png

 

here, do not delegate ipv6 just to make sure no ipv6 delegating happens:

image.png

add it to wan firewall zone:

image.png

then add peer by clicking on "Add peer" and paste your configs:

image.png

image.png

Be also aware that if your router has not been connected for 24 hours or longer, you will have to update your config, you can do it with the api.

Hope that helps

 

  • Like 1
Link to comment
Share on other sites

  • 0

hello, 

First of all, thank for your help and try to solve it with me.

About lucy i have it already before on another router working and didn´t seems so easy to work with the gui, was working but never know if had make the best setup to him...

i understand about the 2 routers connected with the wireguard but will slow the internet speed.

have reseted the computer a few times already and try different setups and configs, every time always the same, i dont know if the linksys is blocking something in internet (or NAT) that asus is not doing it... Because Linksys make de handshake but then the "packets" send and receive dont increase ( thats why i think something is getting blocked after handshake).

im gonna upload some pics with the setupand with what is happen, in those pics you can see the setup, the firewall disconnetcted and the rules for firewall added too, the handshake donne but the packets stay low and ont increase and the firmware from the router (DD_WRT) too, that is the last one.

Again thanks for trying to hel 

Linksys__1.png

Linksys__2.png

Linksys__3.png

Linksys__4.png

Link to comment
Share on other sites

  • 0

With screenshots it is easier to talk about it, thanks.

24 minutes ago, Nuno said:

About lucy i have it already before on another router working and didn´t seems so easy to work with the gui, was working but never know if had make the best setup to him...

As far as I can see from your screenshots, openwrt is way easier to setup wireguard on openwrt, but that is subjective, I suggested openwrt because I know that it not only works but that it works very well, for years they work stable and I am using archer c7 and c5's which are more or less the same router which you try to setup.

At the end it does not matter which wrt you take as long as everything works for you.

27 minutes ago, Nuno said:

i understand about the 2 routers connected with the wireguard but will slow the internet speed.

No, they are connected to each other as a peer and on both you could decide to send traffic over another, but you do not need it, my devices are all connected in vpn despite them not being in the same local network. This way I do not need to open ports or anything to access all my devices on my network.

For wireguard, do not set in allowed ips 0.0.0.0/0, ::/0, as it will route all traffic through that peer.

33 minutes ago, Nuno said:

the handshake donne but the packets stay low and ont increase and the firmware from the router (DD_WRT) too

Do you know why you have setup?:

0.0.0.0/1 and 128.0.0.1/1?

Try instead:

0.0.0.0/0 which should route all the traffic

or:

10.9.0.1/0,10.8.0.1/0,10.13.69.0/0

for dns server set either:

1.1.1.1,1.0.0.1

or

10.9.0.1,10.8.0.1

Then write here about your results.

I am also not very sure about your firewall rules, double check them please.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...