Jump to content
TorGuard
  • 0

DNS leak on Wireguard

Rate this question


user007
 Share

Question

Hi,

From the Ubuntu terminal, I have installed the wireguard, wireguard-tools and resolvconf. And then download the conf file from the torguard generator. Then move that conf file to /etc/wireguard. And then wg-quick up "" I have a stable connection in this way. HOWEVER, when I check my DNS leak from the web, unfortunately my residing country's IP is leaking. Any suggestion? 

Link to comment
Share on other sites

6 answers to this question

Recommended Posts

  • 0

Wireguard in repository is older than latest on repository, however, it should work without issues. I am using wireguard client over all my devices and no dns leaks, check if in your wg0.conf (or whatever it is called) you do use DNS servers. If you dislike 1.1.1.1, 1.0.0.1 dns, you can use 10.9.0.1, 10.8.0.1 too which are torguards internal. I am using 1.1.1.1,1.0.0.1 and have no issues so far for over a year now. I can't reproduce dns leaking, it does not leak anything for me. DNS Leak test shows me torguard's server ip as dns server.

Link to comment
Share on other sites

  • 0
On 7/4/2021 at 6:21 AM, Brainbleach said:

Why not use the native debian torguard client?  No dns leaks on linux when I use that.

The country where I am, heavily censors the internet. sometimes I cannot access the app.

 

On 7/4/2021 at 11:31 AM, 19807409 said:

Wireguard in repository is older than latest on repository, however, it should work without issues. I am using wireguard client over all my devices and no dns leaks, check if in your wg0.conf (or whatever it is called) you do use DNS servers. If you dislike 1.1.1.1, 1.0.0.1 dns, you can use 10.9.0.1, 10.8.0.1 too which are torguards internal. I am using 1.1.1.1,1.0.0.1 and have no issues so far for over a year now. I can't reproduce dns leaking, it does not leak anything for me. DNS Leak test shows me torguard's server ip as dns server.

 

I have opened the conf file and edit the DNS from 1.1.1.1 to 10.9.0.1, but no help, even there was no internet access, I believe that settings suppose to stay as it is.

Link to comment
Share on other sites

  • 1

I remember reading something about Ubuntu and resolvconf causing dns leaks in wireguard.  If I remember correct, you either need to stop systemd-resolved or edit the DNS= line in the wireguard config with a PostUp string.  Hopefully this points you in the right direction. 

  • Like 1
Link to comment
Share on other sites

  • 0
12 hours ago, Kratos said:

I remember reading something about Ubuntu and resolvconf causing dns leaks in wireguard.  If I remember correct, you either need to stop systemd-resolved or edit the DNS= line in the wireguard config with a PostUp string.  Hopefully this points you in the right direction. 

 

Thanks, I stop it with "systemctl stop systemd-resolved" and in Firefox I stop the DoH too, now no DNS leak at all.

But it is weird that I have to go all this even in Ubuntu 21.04, not gets the settings automatically.

Link to comment
Share on other sites

  • 0
On 7/6/2021 at 4:11 PM, user007 said:

I have opened the conf file and edit the DNS from 1.1.1.1 to 10.9.0.1, but no help, even there was no internet access, I believe that settings suppose to stay as it is.

Hello, considering torguard call says following

{"server_public_key":"MYPUBLICKEY=","server_ipv4":"10.XX.0.1/16","client_ipv4":"10.XX.XX.XXX/32","routes":"0.0.0.0/0","dns":["10.9.0.1","10.8.0.1"],"vpn_server_address":"37.XXX.XXX.XX","vpn_server_port":1443}

You clearly can see DNS used:
 

"dns":["10.9.0.1","10.8.0.1"]

I remember @Support explained once that socks5 was not working on 10.9.0.1 but only on 10.8.0.1, this could be here the case too, if 10.9.0.1 did not work, 10.8.0.1 should work if you test, however, using 1.1.1.1,1.0.0.1 should work well.

Also check which dns your router/pc, set there cloudflare's (1.1.1.1,1.0.0.1) or any other available like opendns. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...