Jump to content
TorGuard
  • 0

Why does the mac client activate discrete graphics on macbooks?

Rate this question


Waschbär
 Share

Question

Good day,

I just realised that TorGuard activates my gpu on my macbook pro, draining battery life in the process.

Is this a bug or is there a reason why the client requires this?

Thank you in advance

Screenshot 2021-05-17 at 17.01.51.png

Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 1

I am not sure about Mac, but on linux user controls it, looking at the picture above, dynmaic switching, I at least understand that integrated is used as long as you do not specify your radeon. In Linux with gnome (not sure about other), when you have set dynamic profile (in my case it is nvidia gpu), then all applications launch with intel gpu, if I want to use my nvidia, right click on the app and choose "run with dedicated gpu". This way always intel gpu is used in my case unless I launch it with dedicated. This is quite simple in GUI on Linux.

My first question would be if other applications use same gpu when you launch them with "Dynamic Switching"?

What happens if you set integrated only, can you then launch in simply way (like right click, run with dedicated)? I guess then TorGuard would launch with gpu you want, then during torguard runs swithching the profile, on linux this would require reboot, if on mac if works by simply choosing, then it is worth a try.

 

Link to comment
Share on other sites

  • 0

Thank you for your input!

On your question: it is only TorGuard using the GPU (whether connected or not: just opening the app triggers the discrete gpu). I was able to run TorGuard on integrated by command-line forcing integrated only and had no issue (and discovered that gfxCard has a bug that prevents it from forcing this by itself). This is a semi-permanent solution, but it also begs the question again why MacOS thinks it otherwise should switch GPUs. On the ActivityMonitor it shows which apps use / require the discrete GPU, and TorGuard is immediately flagged, but I am not sure that helps.

Maybe there is some flag that gets set in each app for this?

Screenshot 2021-05-21 at 20.02.49.png

Link to comment
Share on other sites

  • 0

It could be the New " QML " GUI Option in settings which might be triggering the GPU.... Because on Windows the New QML GUI triggers my Nvidia In-Game Overlay to show Frames Per Second and it Mistakenly thinks the Torguard Application is a game and puts the Frames Per Second in the top corner of the Application. So it wouldn't be much of a stretch to think it could be also triggering Increased or Alternate GPU Related Conditions.

In Settings you can Disable QML GUI and revert back to the Classic GUI with QML turned off and see if it still Triggers the GPU Problems your Having and if it doesn't then you will know it is QML that's causing it or not.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...