Jump to content
TorGuard
  • 0

Using ad block DNS and Wireguard apps seem to have no internet connection.


BurntCheese
 Share

Question

Hello! I just got this service and noticed when using wireguard and DNS active my email app and others act as if I have no internet connection.  After playing around I found turning off DNS fixes the issue. How can I fix this? Should I run a different protocol other than wireguard? I’m fairly new to VPN’s coming from a simple pick your server and connect service. I don’t mind tinkering but was wondering if this is a known issue and any simple fixes? 
Thanks in advance. 

Link to comment
Share on other sites

5 answers to this question

Recommended Posts

  • 0

The problem happens when I toggle on “ad blocking dns” from the torguard app. I’ve tried different VPN servers and got the same result. Wireguard seems to work fine when I have the dns off. 
I’m not sure what the best protocol to run is I just figured wireguard since it’s set by default.

Link to comment
Share on other sites

  • 0
8 hours ago, BurntCheese said:

The problem happens when I toggle on “ad blocking dns” from the torguard app. I’ve tried different VPN servers and got the same result. Wireguard seems to work fine when I have the dns off. 
I’m not sure what the best protocol to run is I just figured wireguard since it’s set by default.


I personally have my own DNS blocklist and only use that. But according to a reply from @Support they use some well known blocklists and their custom list to compile the domain block list:

If you are facing issues only with Ad Blocking DNS, I would recommend you open a support ticket and discuss it with them. Make sure to mention the apps/services/websites that are not working. And in the meantime, just use a different DNS. In case you want to block ads, try using AdGuard's DNS:

Default (blocks ads, tracking domains) :
94.140.14.14
94.140.15.15

Family Protection (blocks Default + adult content) :
94.140.14.15
94.140.15.16

You can find more information related to AdGuard here.

You can add those to the app. To do so, just go to Settings ⟶ Static DNS ⟶ Add Static DNS, and add either the default IPs or family protection IPs and save it. Then change the "DNS when VPN is connected" settings to use the newly added DNS. And if you are still unable to use any app/service, try switching to Cloudflare DNS to test if it works with that.

Hope this helps you.

  • Haha 1
Link to comment
Share on other sites

  • 0
On 4/13/2021 at 7:32 AM, BurntCheese said:

The problem happens when I toggle on “ad blocking dns” from the torguard app. I’ve tried different VPN servers and got the same result. Wireguard seems to work fine when I have the dns off. 
I’m not sure what the best protocol to run is I just figured wireguard since it’s set by default.

I have the same issue, i cant even use internal dns servers

Link to comment
Share on other sites

  • 0
12 hours ago, MrFox said:

I have the same issue, i cant even use internal dns servers

 

What TorGuard version are you running and what locations do you use?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...