Jump to content
TorGuard
  • 0

Android v1.59.6 "always-on vpn" is configured in settings but I have to enable the connection all the time

Rate this question


ghostdestroyer
 Share

Question

#1 update In my opinion the Android app is very buggy and I am always having to re-enable the connection and have gone through all settings with a fine tooth comb "auto connect on boot" is on and "always-on vpn" is also selected .

#2 update: re-installed app and turned off "autostart on boot" will see if works better .

#3 update : After sleep and log in tg app says "reconnecting" but never does .

#4 update : Block connections without VPN configured and when not connected can surf internet/ Sometimes VPN reconnects after sleep but rarely

Link to comment
Share on other sites

5 answers to this question

Recommended Posts

  • 0
21 hours ago, ghostdestroyer said:

#1 update In my opinion the Android app is very buggy and I am always having to re-enable the connection and have gone through all settings with a fine tooth comb "auto connect on boot" is on and "always-on vpn" is also selected .

#2 update: re-installed app and turned off "autostart on boot" will see if works better .

#3 update : After sleep and log in tg app says "reconnecting" but never does .

 

Hello,

Can I ask what version of Android your running there?

Link to comment
Share on other sites

  • 0

Thanks for your response , and it seems the longer the phone sleeps the more likely the tg client will drop the connection.

 

Android version 8.1.0 

Link to comment
Share on other sites

  • 0
22 hours ago, ghostdestroyer said:

Thanks for your response , and it seems the longer the phone sleeps the more likely the tg client will drop the connection.

 

Android version 8.1.0 

I think I have a similar issue, and you're right it's after extended periods of inactivity. I'll go to sleep with my phone connect, the TG notification on my phone's pull down menu will state that is is "Enabled". I can verify that it has the correct VPN IP address. I then go to sleep, wake up the next morning, and "Enabled" has been replaced with "Connected", and when I go into the app itself "Connected" is in red font, and it is leaking my real IP address. Only when I pull down the TG notification and click "Resume" does "Connected" change back to "Enabled" and the service resumes.

Link to comment
Share on other sites

  • 0

I faced this issue earlier on but after removing TorGuard from the battery optimization list (you have to remove it from multiple places in case of MIUI) I never faced this issue again. BTW, if you enable the "always on" settings, your IP would not leak if you get disconnected because Android does not connect to the internet AFAIK.

Link to comment
Share on other sites

  • 0

I have a second backup vpn and am using and it works flawlessly !!! very tired of problems with the android TG app !! All of the other devices that I own like ios and macOS work well .

My suggestion to the developers is you really could have a lot more business with apps that are not so buggy get to work

update: Trying TG client V1.59.7 on android again today 5/6/21 , well a alrighty then connectivity always off and hey they just updated today a worthless app , come on man Android app needs serious work .

refer to april 11th post LOL

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...