Jump to content
TorGuard
  • 0

TorGuard Client v4.5.0

Rate this question


Support

Question

Support

============================================
TorGuard PRODUCTION release v4.5.0
============================================
Changelog:Release torguard-v4.5.0, 2021-03-30
===================================

- All platforms: obsolete option "Enable DNS state recovery on start = Ask on start" is removed.
                 The user must decide between "No (forget information)" or "Auto recover".
                 Default is "Auto recover". User with "Ask on start" active, are switched to "Auto recover".
- All platforms: Better high dpi screen support.
- All platforms: QML is enabled by default
- All platforms: "FamilySafe DNS" removed - Temporarily
- All platforms: "Auto login on connect" will not influence the "Hide window to system tray when minimised" option anymore
                 If the "Auto login on connect" option is not enabled, TorGuard will be minimized to tray icon anyway,
                 and a notification will appear, to notify the user that a manual login is required.
- All platforms: create shortcut setting "Use Ad Blocking DNS when connected".
                 This setting will use the "Ad Blocking DNS" when VPN is connected.
                 It is equivalent to select "Use these static DNS" and
                 choose "Ad Blocking DNS" in the "when VPN is connected" combobox.
- Linux & Windows: Fixed bug where TrayIcon was not added when settings were changed.
- MacOSX: Abort Installation on Apple Arm if Rosetta 2 is not installed

Internal Changes:
-----------------

- Linux: improve "Block outside DNS" option
- MacOSX: Adding missing SVG Library for new UI
- All platforms: New UI in **beta** is available in this version with command line option `--enable-qml --showTheme 2` or in Settings
============================================

Downloads

Link to post
Share on other sites

25 answers to this question

Recommended Posts

  • 0
aj_mancuso

After installing the update on the newest version (non beta) of mas os x, TorGuard keeps crashing when trying to change any settings such as Server or Account. The app will not work at all - broken.

Link to post
Share on other sites
  • 0
coltonomore

I have reinstalled it multiple times. Keeps crashing. I cannot change servers or go into settings without it crashing. 

  • Like 1
Link to post
Share on other sites
  • 0
Support

Are you guys able to click restore defaults under the general tab? then retry.

Regards

Link to post
Share on other sites
  • 0
coltonomore
1 hour ago, Support said:

Are you guys able to click restore defaults under the general tab? then retry.

Regards

i am unable to even make it to the settings. I am stuck on the initial screen. Just does not work. Keeps crashing if you click on anything.

Link to post
Share on other sites
  • 0
aj_mancuso
25 minutes ago, coltonomore said:

i am unable to even make it to the settings. I am stuck on the initial screen. Just does not work. Keeps crashing if you click on anything.

The exact same thing is happening to me. I even tried reinstalling it after redownloading.

Link to post
Share on other sites
  • 0

Same for me.

But my solution was I changed from wireguard to openvpn. Then i could select the server, then i changed back to wireguard and it didnt crash

Link to post
Share on other sites
  • 0
coltonomore
2 minutes ago, sam8 said:

Same for me.

But my solution was I changed from wireguard to openvpn. Then i could select the server, then i changed back to wireguard and it didnt crash

This works but if you leave it on wireguard and close the app, it breaks again. You have to switch back and forth each time you open it. 

Link to post
Share on other sites
  • 0
Dom1no

I am having issues with the new Windows version 4.5.0, it works fine but... when you click Settings it closes the Application Completely* the icon down by the clock also disappears. I tried Uninstalling and reinstalling fresh , disabling Antivirus , but when i install an older version settings works fine so i reverted to 4.4.1.

Link to post
Share on other sites
  • 0
Support
11 minutes ago, Dom1no said:

I am having issues with the new Windows version 4.5.0, it works fine but... when you click Settings it closes the Application Completely* the icon down by the clock also disappears. I tried Uninstalling and reinstalling fresh , disabling Antivirus , but when i install an older version settings works fine so i reverted to 4.4.1.

 

Hi - we are investigating - can i ask that you do the following so we can make sure you start fresh.

1) Delete the following folder >> C:\Users\user\AppData\Local\VPNetworkLLC renaming "user" to your OS account name.

2) Open Regedit and delete the following key: HKEY_CURRENT_USER\Software\VPNetworkLLC

3) Reboot (important) and then re-download and install the latest build from here https://torguard.net/downloads.php

Let me know how you go.

Regards

Link to post
Share on other sites
  • 0
Dom1no

I followed your directions exactly* and after rebooting it launched and settings worked "temporarily"

i went into settings and switched to the "Legacy" old UI and hit save then i hit settings again and the program instantly closed again. So it seems the Legacy UI is not working properly in the new 4.5.0 Version only the New UI lets you enter settings the old UI closes the program upon clicking settings.

Link to post
Share on other sites
  • 0

Unable to use this build. Problem has been described adequately by fellow posters. Have reverted to the previous build...

Link to post
Share on other sites
  • 0
Zelf24

Add me as another confirmation of above problematic behavior on both MAC and WINDOWS 4.5.0 builds.  Having an existing default of Wireguard, once you attempt to go to "Settings" Torguard crashes.  If you do not go to "Settings", the app behaves as expected, connecting and disconnecting successfully.

Link to post
Share on other sites
  • 0
Brainbleach

I can't get this new version to connect to any server at all using wireguard.  the app is constantly freezing or crashing.  terrible update.

Link to post
Share on other sites
  • 0
balexter

I experience the same crashing problem as described here in this thread. Cant click a button else crash occurs. 

Link to post
Share on other sites
  • 0
149027_1511348148

Same problems here that are listed above. Support telling me many are getting it working by following  instructions at least similar to above. I was instructed to use CCleaner to clean the registry instead of using the registry editor and navigating to reg entry mentioned above by the admin. I wish the support dept. would have just instructed as above. Maybe it would work. I'm tired of all the hoop jumping I've been going thru with Torguard between the recent Firefox V2 addon not working and trying multiple times to get it working and then just a few days later and the main client release doesn't work and all the hoop jumping with that. Hope somebody gets the bugs lined out.

Link to post
Share on other sites
  • 0
Support

Hello,

To fix the crash please use one of the below instructions:

Windows:

1) Delete the following folder >> C:\Users\user\AppData\Local\VPNetworkLLC renaming "user" to your OS account name.

2) Open Regedit and delete the following key: HKEY_CURRENT_USER\Software\VPNetworkLLC

3) Retry the app.

Mac:

1) Delete the Torguard app from the applications folder and empty your trash

3) Remove this folder:   ~/Library/Application Support/VPNetworkLLC

4) Reboot + Reinstall TG Client latest version here https://torguard.net/downloads.php

Linux:

1) Remove this config file: ~/.config/VPNetworkLLC/TorGuard.conf

2) Restart the app.

Regards

Link to post
Share on other sites
  • 0
John19
19 hours ago, Ashutosh said:

 

 

This isn't working. "Unknown option 'showTheme'" and nothing in settings.

Link to post
Share on other sites
  • 0
Ashutosh
On 4/2/2021 at 12:12 AM, John19 said:

This isn't working. "Unknown option 'showTheme'" and nothing in settings.

Are you using the latest client? It worked for me on Fedora. And yes, you will not see anything in settings right now, that's coming in the next release:

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...