Jump to content
TorGuard
  • 0

MTU size problem for WireGuard on Windows 10

Rate this question


desilent
 Share

Question

Hello everyone,

 

I recently acquired TorGuard and I am very happy so far.

I have an issue with the MTU-Settings specifically for the WireGuard Protokoll and VPN Adapter.

 

With the default 1420 MTU for the wg-adapter it connects to the server but I literally have no internet. I went ahead and tested which MTU I actually need and I ended up with 1292 MTU size. (1264 no more ping errors  + 28 = 1292) I went ahead and connected via WireGuard one more time and changed this specific value via PowerShell "netsh interface ipv4 set subinterface “wg-adapter” mtu=1292 store=persistent" and voila the WireGuard connection now works flawlessly.

 

My issue is that there is literally no way to permenantely change this MTU size for the WireGuard protocol. Everytime I disconnect/reconnect to another server the Virtual adapter is removed and added again with the default values.

 

Is there any way to permamently change the MTU size for the Tunnel adapter?

 

Thanks in advance.

  • Like 1
Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Having same issue, and is causing a particular torrent site not to work. Any ideas if there is a fix coming for this?

Link to comment
Share on other sites

  • 0
27 minutes ago, Jamstuff said:

Having same issue, and is causing a particular torrent site not to work. Any ideas if there is a fix coming for this?


If you Connect to a different Server does the website load, if you change to a Different Server and the site Loads then it is Probably Not a MTU Problem But Rather that site Might Be blocking that specific IP or Country/Location
As Far as i know Changing MTU For Wireguard is usually Not Needed, in the Torguard Settings do you have IPV6 Disabled?

I would Suggest Opening a Support Ticket and Talking with Support For Guidance if you Continue to Have Problems > https://torguard.net/supporttickets.php

Link to comment
Share on other sites

  • 0

@desilentthe most simple and currently the only solution for you is to use original wireguard client instead of TorGuard client and add mtu value to your wireguard config, that is it, resolved then. I was for some reason thinking that it is configuarable over tg client. In general using original client is solution to many issues related to the TG client.

Link to comment
Share on other sites

  • 0
On 3/5/2021 at 2:33 PM, desilent said:

Hello everyone,

 

I recently acquired TorGuard and I am very happy so far.

I have an issue with the MTU-Settings specifically for the WireGuard Protokoll and VPN Adapter.

 

With the default 1420 MTU for the wg-adapter it connects to the server but I literally have no internet. I went ahead and tested which MTU I actually need and I ended up with 1292 MTU size. (1264 no more ping errors  + 28 = 1292) I went ahead and connected via WireGuard one more time and changed this specific value via PowerShell "netsh interface ipv4 set subinterface “wg-adapter” mtu=1292 store=persistent" and voila the WireGuard connection now works flawlessly.

 

My issue is that there is literally no way to permenantely change this MTU size for the WireGuard protocol. Everytime I disconnect/reconnect to another server the Virtual adapter is removed and added again with the default values.

 

Is there any way to permamently change the MTU size for the Tunnel adapter?

 

Thanks in advance.

 

We will be adding an option to adjust MTU just shortly, can i ask, how are your speeds when using this MTU?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...