Jump to content
TorGuard
  • 0

WireGuard + Transmission + Port Forwarding

Rate this question


Code

Question

Hi there.

Can someone explain how to port forward (with examples) using WireGuard + Transmission (BitTorrent Client)?

I cannot get it to work.

Code.

Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0
19807409
58 minutes ago, Code said:

Hi there.

Can someone explain how to port forward (with examples) using WireGuard + Transmission (BitTorrent Client)?

I cannot get it to work.

Code.

hello, It all depends on what you use. If you use TorGuard client then port forwarding should work. To enable port forwarding you need to request it (but I assume you know/did this part already).

That should be it.

Now about torrent, I am not sure what is asked, as if your port forward works, then transmission should work too. I remember that qbittorrent did not work at all unitl I set it to use wg0 interface (or torguard-wg if using torguard client).

If you use Openwrt, then something like this in your /etc/config/firewall would do the job (assuming your router forwards it to its internal lan), assuming your transmission which runs on 192.168.1.123 (I added some dummy port range from 12345-12400😞

config redirect
	option target 'DNAT'
	option name 'Open-Transmission-ports'
	option src 'wan'
	option src_dport '12345-12400'
	option dest 'lan'
	option dest_ip '192.168.1.123'
	option dest_port '12345-12400'

config rule
	option src '*'
	option target 'ACCEPT'
	option proto 'tcp udp'
	option name 'Allow-Transmission-ports-inbound'
	option dest_port '12345-12400'

config rule
	option src 'wan'
	option dest 'lan'
	list dest_ip '192.168.1.123'
	option target 'ACCEPT'
	option src_port '12345-12400'
	option name 'Allow-Transmission-forward'
	option dest_port '12345-12400'

 

Hope that helps you, I probably cant help more as you even did not write what exactly does not work, how you have set it up, which soft/os you use etc...

Link to post
Share on other sites
  • 0
2 hours ago, 19807409 said:

hello, It all depends on what you use. If you use TorGuard client then port forwarding should work. To enable port forwarding you need to request it (but I assume you know/did this part already).

That should be it.

Now about torrent, I am not sure what is asked, as if your port forward works, then transmission should work too. I remember that qbittorrent did not work at all unitl I set it to use wg0 interface (or torguard-wg if using torguard client).

If you use Openwrt, then something like this in your /etc/config/firewall would do the job (assuming your router forwards it to its internal lan), assuming your transmission which runs on 192.168.1.123 (I added some dummy port range from 12345-12400😞






config redirect
	option target 'DNAT'
	option name 'Open-Transmission-ports'
	option src 'wan'
	option src_dport '12345-12400'
	option dest 'lan'
	option dest_ip '192.168.1.123'
	option dest_port '12345-12400'

config rule
	option src '*'
	option target 'ACCEPT'
	option proto 'tcp udp'
	option name 'Allow-Transmission-ports-inbound'
	option dest_port '12345-12400'

config rule
	option src 'wan'
	option dest 'lan'
	list dest_ip '192.168.1.123'
	option target 'ACCEPT'
	option src_port '12345-12400'
	option name 'Allow-Transmission-forward'
	option dest_port '12345-12400'

 

Hope that helps you, I probably cant help more as you even did not write what exactly does not work, how you have set it up, which soft/os you use etc...

Port forwarding is not working here (port is always closed).

 

1. I've disabled the firewall on my PC;

2. Set the appropriate port I want open in Transmission;

3. Configured port forwarding correctly in OpenWrt.

 

I think the problem is in the port forwarding section of TorGuard (login page).

Back when I was using OpenVPN port forwarding was working.

Some screenshots from the TorGuard Port Forwarding page would be helpful.

 

Code.

Link to post
Share on other sites
  • 0
19807409
2 hours ago, Code said:

Port forwarding is not working here (port is always closed).

 

1. I've disabled the firewall on my PC;

2. Set the appropriate port I want open in Transmission;

3. Configured port forwarding correctly in OpenWrt.

 

I think the problem is in the port forwarding section of TorGuard (login page).

Back when I was using OpenVPN port forwarding was working.

Some screenshots from the TorGuard Port Forwarding page would be helpful.

 

Code.

I wrote you quite a long reply and explaining everything, together with screenshots for which you asked.

 

@Support it is very annoying if one wastes time in writting long reply with all the screenshots, just to see this after clicking submit reply, the irony => look at the IP, it is torguards

grafik.png

By clicking back, nothing was in cache => lost

@Code this is very annoying after writting you quite a long reply with screenshots like you asked, but I hope you understand that I will not rewrite it now. To keep it short, paste settings from above post to /etc/config/firewall, then reboot and see by yourself. I assume you want to edit them and this would be appropriate way of import it. For the rest, you are wrong in my opinion in all your points, but the explanation about it is gone by torguard forum blocking its own ip. I might reply at some later point.

Link to post
Share on other sites
  • 0
5 minutes ago, 19807409 said:

I wrote you quite a long reply and explaining everything, together with screenshots for which you asked.

 

@Support it is very annoying if one wastes time in writting long reply with all the screenshots, just to see this after clicking submit reply, the irony => look at the IP, it is torguards

grafik.png

By clicking back, nothing was in cache => lost

@Code this is very annoying after writting you quite a long reply with screenshots like you asked, but I hope you understand that I will not rewrite it now. To keep it short, paste settings from above post to /etc/config/firewall, then reboot and see by yourself. I assume you want to edit them and this would be appropriate way of import it. For the rest, you are wrong in my opinion in all your points, but the explanation about it is gone by torguard forum blocking its own ip. I might reply at some later point.

No worries.

I'll get it sorted out.

 

Code.

Link to post
Share on other sites
  • 0
19807409
1 minute ago, Code said:

No worries.

I'll get it sorted out.

 

Code.

I do not worry :), for me it works, just wanted to help if I can, as I said, settings which I posted are from working openwrt with torguards wireguard which are currenlty in use, by that, I am not supposing that it works, I know that it works. Its easy to check for you if port forwarding works on your router, simply add/change ssh port to use a port which you opened on torguard, then you should be able to connect to your router if your firewall settings are good, if you cant connect then your settings are bad.

If you believe that on torguards side something does not work, then try it with torguard client which 100% works, if then your port on your PC is not open, then contact support, if it is open, then issue is on your firewall/wireguard configuration on your openwrt device which I assume is.

Link to post
Share on other sites
  • 0

I contacted support and port forwarding is working now.

You have to generate a new WireGuard configuration and load it so the port forwarding takes effect.

 

Code.

Link to post
Share on other sites
  • 0
19807409
13 minutes ago, Code said:

I contacted support and port forwarding is working now.

You have to generate a new WireGuard configuration and load it so the port forwarding takes effect.

 

Code.

Thats good news. In the reply which got banned, I explained to you that you should recreate the config.

According to the reply, I also doubt that TorGuard had to repair or did repair anything. Point is, that if you want to use dedicated/port forwarding ip with wireguard, then you can use that IP only for 1 connection, meaning that if you connect as example from another PC with TorGuard client to your port forwarded IP, then TorGuard client would use different public key which invalidates any other active config.

So, in short, the issue which you had is not gone, here it is important for you to know what caused the issue as it will repeat itself if you do not know it.

This is especially an issue if somebody is actually using some shared IP, here is example of how easily you can invalidate your config without knowing it:

1. you create new fresh valid config for openwrt with the api or config generator under your account which works and you use it

2. On some PC you have installed torguard client, then for a test or by mistake you connect to your port forward ip. thats it, from that moment, your router would stop working. The only way for you to use same IP without to invalidate it would be to use another protocol or port, but for wireguard there is no other port leaving you no options so far.

 

By that, it is wrong statement about the issue you had (at least in my view): "You have to generate a new WireGuard configuration and load it so the port forwarding takes effect."

Assuming that for connecting you have to create one, it means, only current/latest one is valid and that only for 12 hours. Registering new public keys (be it by tg client or api) invalidates every previous settings. That would be in my eyes way more correct reply from support.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...