Jump to content
TorGuard
  • 0

Installing torguard app on Debian

Rate this question


James8078

Question

James8078

hi,

 

I try to install linux app on my debian laptop.

it does not work, here what I do on my terminal: Also, I tried with ''apt install'', and now whatever I want to install or uninstall, I get that:

Reading Package Lists ... Done
Building the dependency tree
Reading status information ... Done
E: The torguard package must be reinstalled, but its archive cannot be found.

 

XXX: ~ / Downloads $ sudo dpkg -i torguard-latest-amd64.deb
(Reading the database ... 179103 files and directories already installed.)
Preparing to unpack torguard-latest-amd64.deb ...
Unpacking torguard (4.3.0) on (4.3.0) ...
/var/lib/dpkg/info/torguard.postrm: 9: /var/lib/dpkg/info/torguard.postrm: update-desktop-database: not found
dpkg: warning: old torguard package post-removal script subprocess returned error exit status 127
dpkg: attempting to run the script for the new package instead ...
/var/lib/dpkg/tmp.ci/postrm: 9: /var/lib/dpkg/tmp.ci/postrm: update-desktop-database: not found
dpkg: error processing torguard-latest-amd64.deb archive (--install):
 new torguard package post-removal script subprocess returned error exit status 127
/var/lib/dpkg/tmp.ci/postrm: 9: /var/lib/dpkg/tmp.ci/postrm: update-desktop-database: not found
dpkg: error while cleaning up:
 new torguard package post-removal script subprocess returned error exit status 127
Processing of deferred actions ("triggers") for mime-support (3.62) ...
Errors were encountered during execution:
 torguard-latest-amd64.deb

 

Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0
19807409
9 hours ago, James8078 said:

hi,

 

I try to install linux app on my debian laptop.

it does not work, here what I do on my terminal: Also, I tried with ''apt install'', and now whatever I want to install or uninstall, I get that:

Reading Package Lists ... Done
Building the dependency tree
Reading status information ... Done
E: The torguard package must be reinstalled, but its archive cannot be found.

 

XXX: ~ / Downloads $ sudo dpkg -i torguard-latest-amd64.deb
(Reading the database ... 179103 files and directories already installed.)
Preparing to unpack torguard-latest-amd64.deb ...
Unpacking torguard (4.3.0) on (4.3.0) ...
/var/lib/dpkg/info/torguard.postrm: 9: /var/lib/dpkg/info/torguard.postrm: update-desktop-database: not found
dpkg: warning: old torguard package post-removal script subprocess returned error exit status 127
dpkg: attempting to run the script for the new package instead ...
/var/lib/dpkg/tmp.ci/postrm: 9: /var/lib/dpkg/tmp.ci/postrm: update-desktop-database: not found
dpkg: error processing torguard-latest-amd64.deb archive (--install):
 new torguard package post-removal script subprocess returned error exit status 127
/var/lib/dpkg/tmp.ci/postrm: 9: /var/lib/dpkg/tmp.ci/postrm: update-desktop-database: not found
dpkg: error while cleaning up:
 new torguard package post-removal script subprocess returned error exit status 127
Processing of deferred actions ("triggers") for mime-support (3.62) ...
Errors were encountered during execution:
 torguard-latest-amd64.deb

 

update-desktop-database can not be found means that this command is not available, probably this should resolve your issue with that error:

sudo apt update && sudo apt install -y desktop-file-utils

You can find more info about that (and other packages) here: https://packages.debian.org/stretch/desktop-file-utils

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...