Jump to content
TorGuard
  • 0

Can't stop/remove Torguard service from Raspberry Pi

Rate this question


disk1of3
 Share

Question

I followed the steps here https://torguard.net/knowledgebase.php?action=displayarticle&id=174 to set up Torguard on the Raspberry Pi and it works great.  But the problem is I need to reverse it/uninstall it/whatever it's called.

I do the

curl -s checkip.dyndns.org|sed -e 's/.*Current IP Address: //' -e 's/<.*$//'

to check my IP and it's a Torguard IP.

I do

sudo killall -9 openvpn

to stop it, then I check the IP again and it's my local IP.  Perfect!  Except it only lasts for like 10 seconds before it reverts back to a Torguard IP.

How do I completely remove Torguard from my Raspberry Pi?

Link to comment
Share on other sites

6 answers to this question

Recommended Posts

  • 0

Hey :) 

The only thing i can think of is maybe you forgot to install the package needed for the killall command to work properly. Without the package the killall command doesn't actually kill"all" which can cause the program to close and to launch again. I believe the command to install the package is >  

sudo apt-get install psmisc  


That's the only thing i can think of hope it helps.

Link to comment
Share on other sites

  • 0

Thank you very much for the reply!  Here's what it gave me.

Reading package lists... Done
Building dependency tree
Reading state information... Done
psmisc is already the newest version (23.2-1).
The following packages were automatically installed and are no longer required:
  libmicrodns0 rpi-eeprom-images
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

 

Link to comment
Share on other sites

  • 0

i have not used Raspberry pi or linux or anything in so long i can not remember exactly, but i do know a couple years ago i had the exact same problem when using the killall command the program would end but eventually start again if you have the package i described above installed then i would imagine the fix would be as simple as using a different command so instead of,  sudo killall -9 openvpn  ,, maybe it needs to be a different command or a permission or package or dependency is missing.

I stick with windows these days as it is easier , 

Is the killswitch enabled? that could be restarting the vpn after you run the command to shut it down the killswitch might be restarting it.
you can try using some diff command though to see if it makes any difference something like , 

sudo apt-get update  << this might help if your missing anything*
sudo pkill openvpn

You will have to tinker with it for awhile as i just do not remember all the commands . Hopefully someone with more knowledge is able to help.

Link to comment
Share on other sites

  • 0

Thank you, this works better, but it still re-enables torguard after a restart of the system.  Any ideas?

Link to comment
Share on other sites

  • 0

That is likely a setting in a config file,  /etc/init.d/openvpn  ,,,   /etc/default/openvpn .. i believe there should be a config file of some kind in that area and inside should be an option for AutoStart you will have to search through and try and find the options and where they are located.

There is also the 2nd option of Disabling openvpn from boot using a command like, sudo systemctl disable openvpn  , the command may be different* depending on your version of raspberry pi but doing this would mean you would need to run a similar command each time to re-anable it or start/stop it possibly so you will need to know all the commands as this disables the service i believe so there would be commands like start / stop / disable / reenable.


There is a UI version of Torguard available i think for Raspberry pi which would give the graphical interface i would imagine changing all the settings and everything would be much easier using the Torguard app.


 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...