Jump to content
TorGuard
  • 0

Losing Internet Speed with VPN on

Rate this question


SteelCityColt

Question

SteelCityColt

Post moving house, I'm still ironing out some of the niggles of changing infrastructure. I've gone from one ISP (Virgin), whose kit allowed modem mode on their router, to another who doesn't (EE). After some initial fun and games I've got this passing through my full connection (circa 270 Mbit/s) to pfSense and then onto that LAN.

However I still can't get my setup to hit full speed while using a Open VPN client to connect to TorGuard. Tops out circa 130 Mbit/s. Now my previous connection with Virgin was only 120 so I'm starting to wonder have I hit a hardware limit on my pfSense box? Testing the TG client on my desktop I can connect random servers around the world and easily top 200 so I don't think it's a TG issue.

My pfSense box specs:

Intel(R) Atom(TM) CPU E3845 @ 1.91GHz

4 CPUs: 1 package(s) x 4 core(s)

AES-NI CPU Crypto: Yes (active)

8026 MiB.

NICs - Intel(R) PRO/1000 Network Connection ver 2.5.3

I've so far tried messing around with the client settings (fast-io, buffer size, tun-mtu) but no joy at all so far. Max I've hit is 150. Tried enabling NCP, turning on hardware crypto, and using CBC instead but no real difference. 

Link to post
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...