Jump to content
TorGuard
  • 3

TorGuard 4.1.0 Wireguard VPN connection issue

Rate this question


Lars A.
 Share

Question

6 answers to this question

Recommended Posts

  • 1

Definitely had a lot of issues with this as well on multiple computers with various platforms (macOS and Linux).  I'm pretty sure this is a bug with the way the app saves / applies / loads configuration settings.  To work around this, I found that it's best to delete any servers you've configured, click the "Restore Defaults" button (I had to do this even on a fresh installation), and close the app entirely.  Then, I added my server information in the settings and closed the app again.  Afterwards, I am able to log in without the handshake error.  For whatever reason, a combination of resetting to the defaults even on a fresh install and closing the app after every settings change was the only way I was able to get it to authenticate correctly.  Definitely a frustrating bug.

  • Thanks 1
Link to comment
Share on other sites

  • 0
15 minutes ago, dustkick said:

Definitely had a lot of issues with this as well on multiple computers with various platforms (macOS and Linux).  I'm pretty sure this is a bug with the way the app saves / applies / loads configuration settings.  To work around this, I found that it's best to delete any servers you've configured, click the "Restore Defaults" button (I had to do this even on a fresh installation), and close the app entirely.  Then, I added my server information in the settings and closed the app again.  Afterwards, I am able to log in without the handshake error.  For whatever reason, a combination of resetting to the defaults even on a fresh install and closing the app after every settings change was the only way I was able to get it to authenticate correctly.  Definitely a frustrating bug.

 

This worked for me too! Restored to default, quit the app, logged in using OpenVPN and then switched to Wireguard.


I hope they fix this!

Link to comment
Share on other sites

  • 0

Yep "Restore Defaults" in the settings worked for me too. It's a fresh install on Pop!_OS so I was skeptical this would be the answer but it worked.

 

Version 4.4.0

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...