Please uncheck "Active Firewall" under more settings --> network tab. Regards