Jump to content
TorGuard
  • 0
RCM

TorGuard Icon Disappears from Tray

Rate this question

Question

RCM

Since updating to version 4.01, the green TorGuard icon in the system tray disappears randomly.  I'm still connected but can no longer summon the interface. So if I want to disconnect or change servers, I'm out of luck. Is this a known bug and can you suggest a solution? Also, are WireGuard config files available? I've looked but can't find them. Thanks.

Share this post


Link to post
Share on other sites

15 answers to this question

Recommended Posts

  • 0
Support
8 hours ago, RCM said:

Since updating to version 4.01, the green TorGuard icon in the system tray disappears randomly.  I'm still connected but can no longer summon the interface. So if I want to disconnect or change servers, I'm out of luck. Is this a known bug and can you suggest a solution? Also, are WireGuard config files available? I've looked but can't find them. Thanks.

 

Hi RCM, it’s not hiding in the system tray at all?

Share this post


Link to post
Share on other sites
  • 0
RCM

No, it vanishes entirely.  I think I know what you mean by hiding but it's just gone. This happens after I've been connected for a while. It's happened twice while running qbittorrent and once just out of the blue. It's odd because the connection is still good (verified at various check IP sites). I'll also mention that I was using Wireguard in each instance. That might not be relevant. It doesn't appear on the taskbar, either.

Share this post


Link to post
Share on other sites
  • 0
Support

Could you enable debugging under the debug tab, set it to log to file, note the location they are held - restart the app, once this happens grab the logs and send them to [email protected] - please

Share this post


Link to post
Share on other sites
  • 0
djsi

I have had this happen with earlier releases a couple of times,but was able to click the  ^ up arrow that shows hidden icons located to the bottom right next to the speaker in windows,and then click the green torguard circle which immediately brought back the Disappeared torguard icon.

Share this post


Link to post
Share on other sites
  • 0
List

No, this is different than what you're thinking djsi. It's completely gone. I'm experiencing it as well.

 

I have it set to have an icon in the task tray, and I keep the program interface up. But they both disappear. Opening up the interface through the executable opens up another one entirely. However, the connection is still working, and can be seen if you hover over the internet connection and when checking the IP. I haven't had it happen when I'm looking at the screen. The 2 times it happened to me, was when I locked my screen and do other things.

 

I thought it might've been a wireguard thing as it happens when I use that, but it seems not to be.

Share this post


Link to post
Share on other sites
  • 0
Support
2 hours ago, List said:

No, this is different than what you're thinking djsi. It's completely gone. I'm experiencing it as well.

 

I have it set to have an icon in the task tray, and I keep the program interface up. But they both disappear. Opening up the interface through the executable opens up another one entirely. However, the connection is still working, and can be seen if you hover over the internet connection and when checking the IP. I haven't had it happen when I'm looking at the screen. The 2 times it happened to me, was when I locked my screen and do other things.

 

I thought it might've been a wireguard thing as it happens when I use that, but it seems not to be.

 

Can you enable debugging + restart the app, then try to reproduce the problem and send the log explaining the issue to [email protected]? thanks

Share this post


Link to post
Share on other sites
  • 0
List

Sure, I'll let you know if it happens again.

Share this post


Link to post
Share on other sites
  • 0
List

By the way, to the OP, I was able to disconnect by opening up another interface and trying to connect. It'll give a warning, and if you proceed, it'll disconnect the current connection and attempt a new one.

Share this post


Link to post
Share on other sites
  • 0
Support

Thanks for the logs guys, we are looking into this.

Regards

Share this post


Link to post
Share on other sites
  • 0
RCM
13 hours ago, List said:

By the way, to the OP, I was able to disconnect by opening up another interface and trying to connect. It'll give a warning, and if you proceed, it'll disconnect the current connection and attempt a new one.

Thanks for the tip. Will give it a try.

Share this post


Link to post
Share on other sites
  • 0
List

Is there a way to generate a log? Or does it generate a log when you exit Torguard?

 

It happened again, but not sure if my logs captured the time it happened, as the last update to it was 3 hours prior from me noticing it.

 

image.png.16a4ee5c45ba4d1b5f7374c3cb5b3bf2.png

Share this post


Link to post
Share on other sites
  • 0
Support
9 hours ago, List said:

Is there a way to generate a log? Or does it generate a log when you exit Torguard?

 

It happened again, but not sure if my logs captured the time it happened, as the last update to it was 3 hours prior from me noticing it.

 

image.png.16a4ee5c45ba4d1b5f7374c3cb5b3bf2.png

 

We are working on this now - what windows 10  version and build number are you running?

Share this post


Link to post
Share on other sites
  • 0
List

Windows 10 Home, Version 1903 Build 18362.476.

Share this post


Link to post
Share on other sites
  • 0
Support
11 hours ago, List said:

Windows 10 Home, Version 1903 Build 18362.476.

 

Thanks, we are onto this.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...