Jump to content
TorGuard
  • 0
Sign in to follow this  
Guest

What ports need to be open?

Rate this question

Question

Guest

So.. What ports need to be open on my router? I get:

"torguard.net: Error: Success, Your torrent client IP is: 184.75.209.2"

 

but for other torrents:

"openbittorrent.com: Error: "

 

And no downloading or peers are showing.

 

I am using Deluge on Linux.

 

libtorrent: 0.16.11.0

Share this post


Link to post
Share on other sites

15 answers to this question

Recommended Posts

  • 0
Guest

weird, changed nothing and now it's downloading. I guess it takes a while for the system to kick itself going?

Share this post


Link to post
Share on other sites
  • 0
Support

Hello - it may have just took a little time to connect - sometimes this happens, it really depends on the tracker.

 

If it fails, try a Netherlands socks5 IP.

 

Regards

Share this post


Link to post
Share on other sites
  • 0
Guest

holy crap. I thought nl would be slow but I'm getting better speeds than before torguard. Thanks!

Share this post


Link to post
Share on other sites
  • 0
Guest

Was still getting kind of wonky connections, turns out I just had to turn off NAT-PMP and LSD (local service discovery) in deluge.

Share this post


Link to post
Share on other sites
  • 0
Support

Thanks for letting us know! Hope all is now working great :)

 

Regards

Share this post


Link to post
Share on other sites
  • 0
Guest

Well I tried adding some torrents remotely and they're just sitting there with no peers or anything like that - I'll be fiddling with toggles when I get home.

Share this post


Link to post
Share on other sites
  • 0
Guest

State: Downloading Down Speed: 0.0 KiB/s Up Speed: 0.0 KiB/s

Seeds: 0 (-1) Peers: 0 (-1) Availability: 0.00

Size: 0.0 KiB/0.0 KiB Ratio: -1.000

Seed time: 0 days 00:00:00 Active: 0 days 04:33:27

 

 

from deluge-console FYI

Share this post


Link to post
Share on other sites
  • 0
Support

Hi - is this using magnet links by any chance ?

 

Regards

Share this post


Link to post
Share on other sites
  • 0
Support

I would suggest you use the torrent files instead yes.

 

Many clients have issues with UDP via magnet links.

 

Regards

Share this post


Link to post
Share on other sites
  • 0
Guest

So, here's the thing. I tried torrent files and I get the same thing. It's not until I change the proxy URL that deluge actually kick-starts the torrent - has anyone had any experience with something like this?

 

Secondarily - I have a router with tomato installed, is there some settings on there I need to tweak? I have opened port 1080 and my torrent ports are all open as well.

 

To recap: Torrents only work if I change the proxy url *after* I add the torrents.

 

If there is any further information you need from me let me know, I can run commands if needed :)

Share this post


Link to post
Share on other sites
  • 0
Support

Hello - it may be due to the fact that with magnet links it fetches Metadata via UDP which some version of Deluge have an issue with.

 

Just make sure users are about to connect outgoing to port 1080, that should be enough.

 

Regards

Share this post


Link to post
Share on other sites
  • 0
Guest

Hrm.. OK. I'm going to install deluge from source and install a newer libtorrent: 0.16.11.0. I will report back with results :)

Share this post


Link to post
Share on other sites
  • 0
Support

Let me know how that goes :)

 

Regards

Share this post


Link to post
Share on other sites
  • 0
Guest

I think I have to compile a later deluge than 1.3.6 because it hangs on me, with ssl handshake errors on the deluge server, and even when I run it in classic mode, it still won't initiate torrents properly.

 

I have switched to qbitorrent and it seems to be working just fine.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...