Jump to content
  • 0

Port forwarding for Emby

Rate this question



Thank you for taking the time to read this.

I'm having difficulty forwarding the port for Emby.

I have my Emby server running on Raspberry Pi 4 using the Retropie image.  Everything runs great on my local network I have set up.

I've set my WAN port on Emby to 8090 since 8096 is already in use in the TG IP.

I test it by turning the Wifi off on my phone and trying the app and the browser using the WAN ip:port.  It doesn't connect.

The online port checker says the port is closed.

Any help would be very much appreciated.

Annotation 2020-08-11 190819.png

Annotation 2020-08-11 192145.png

Annotation 2020-08-11 192304.png

Annotation 2020-08-11 193214.png

Link to comment
Share on other sites

7 answers to this question

Recommended Posts

  • 0

I have a similar setup with my plex server. It could be a problem with your IPtables. 

I mostly use ubuntu so im not sure if the commands are the same, but you can try:


sudo iptables -A INPUT -p tcp --dport 8090 -j ACCEPT

sudo iptables -A INPUT -p udp --dport 8090 -j ACCEPT


And if it works then do:

sudo apt-get install iptables-persistent 

In order for it to stick after a reboot.

I am a novice myself, so i might be completely wrong here, but it's worth a shot.

Link to comment
Share on other sites

  • 0

Thank you for the reply, I hadn't tried this before so I was hopeful, however it doesn't work for me.

I tried it with VPN on, VPN off, DMZ on, direct connected to the modem.

Not sure what's going on.

Link to comment
Share on other sites

  • 0

Thank you again.  Yeah I input the iptable commands in the terminal.  And Ubuntu commands should be the same since they're both debian. 

I've got port forwarding set up on my router for both udp/tcp port 8090. As well as dhcp reservation.  And for when the VPN is on I have both udp/tcp for 8090 in TorGuard.

Link to comment
Share on other sites

  • 0

Okay so your VPN is set up through your router? I have my own running on a DD-WRT router, and i had to specifiy which ip gets what port in the firewall settings. If you coincidentally also run DD-WRT the command is:


iptables -I FORWARD -i tun1 -p udp -d 192.168.1.xx --dport 8090 -j ACCEPT
iptables -I FORWARD -i tun1 -p tcp -d 192.168.1.xx --dport 8090 -j ACCEPT
iptables -t nat -I PREROUTING -i tun1 -p tcp --dport 8090 -j DNAT --to-destination 192.168.1.xx
iptables -t nat -I PREROUTING -i tun1 -p udp --dport 8090 -j DNAT --to-destination 192.168.1.xx


iptables -I FORWARD -s 192.168.1.xx -o $(nvram get wan_iface) -j DROP
iptables -I FORWARD -s 192.168.1.xx -o $(nvram get wan_iface) -j DROP

Also, when using torguard port forward you dont have to port forward on your router, it does nothing. 

Link to comment
Share on other sites

  • 0

No, sorry I should have been more clear.  My vpn is running on the raspberry pi itself.

Thank you for taking the time to help with DD-WRT though, I may use that in the future.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...