Jump to content
TorGuard

Newbie question: Why is WireGuard so slow?

Rate this topic


Recommended Posts

Hello and good morning from Bangkok!

I am a VPN illiterate so don´t shoot me for asking this question ... 🙂
 

I had read about WireGuard and thought I would try it. First, I installed the WireGuard app on my iPhone. Then I logged into my account here and found the page where I "enabled" the Singapore server for WireGuard, downloaded the config file, emailed it to myself so that I could access it on my iPhone and then "loaded" (or whatever the correct term is) to WireGuard. Now, the next thing I did was running speedtests. First, I used the standard Torguard iPhone app, selected the Torguard server in Singapore and using IKEv2 protocol. I then went to speedtest.net and selected the Singtel server for the test. Download speed came in at around 125 Mbps. I then used the Wireguard app and activated the "Singapore" connection/protocol in "settings". I then re-ran the same speed test and I only got around 24 Mbps. Surprised by the results I re-ran all tests a few more times but always with the same end results. 

Now, me being new to VPN etc, based on what I had read before I was expecting the speed using WireGuard to be faster. So seeing it down by 80% surprised me, to say the least. What am I missing? Am I doing something wrong with how I set it up?

 

Link to post
Share on other sites
Support
7 hours ago, DUS said:

Hello and good morning from Bangkok!

I am a VPN illiterate so don´t shoot me for asking this question ... 🙂
 

I had read about WireGuard and thought I would try it. First, I installed the WireGuard app on my iPhone. Then I logged into my account here and found the page where I "enabled" the Singapore server for WireGuard, downloaded the config file, emailed it to myself so that I could access it on my iPhone and then "loaded" (or whatever the correct term is) to WireGuard. Now, the next thing I did was running speedtests. First, I used the standard Torguard iPhone app, selected the Torguard server in Singapore and using IKEv2 protocol. I then went to speedtest.net and selected the Singtel server for the test. Download speed came in at around 125 Mbps. I then used the Wireguard app and activated the "Singapore" connection/protocol in "settings". I then re-ran the same speed test and I only got around 24 Mbps. Surprised by the results I re-ran all tests a few more times but always with the same end results. 

Now, me being new to VPN etc, based on what I had read before I was expecting the speed using WireGuard to be faster. So seeing it down by 80% surprised me, to say the least. What am I missing? Am I doing something wrong with how I set it up?

 

 

The WireGuard only servers are very limited - WireGuard is coming to all servers very soon once the app is finished.

Regards

Link to post
Share on other sites
11 minutes ago, Support said:

 

The WireGuard only servers are very limited - WireGuard is coming to all servers very soon once the app is finished.

Regards

 

Thanks for the reply! 

I am not sure, however, if that explains my observation that when connecting to one of your "WireGuard" servers, my speed drops by 80%. Well, maybe it did answer my question but I don´t understand it.... :-))

Link to post
Share on other sites
Support
13 minutes ago, DUS said:

 

Thanks for the reply! 

I am not sure, however, if that explains my observation that when connecting to one of your "WireGuard" servers, my speed drops by 80%. Well, maybe it did answer my question but I don´t understand it.... :-))

 

They are very limited and many users use them so speeds will take a hit - once implemented inside our TG app all servers will support WireGuard.

Regards

  • Like 2
Link to post
Share on other sites
kratoscratus1891

Hi, maybe the experience may vary but currently I'm on Bangkok also. I have no problems using WireGuard and my only problem is I can't wait for the all servers to be on Wireguard. Maybe try on other devices. I'm using it on my PC. 

Link to post
Share on other sites
21 hours ago, kratoscratus1891 said:

Hi, maybe the experience may vary but currently I'm on Bangkok also. I have no problems using WireGuard and my only problem is I can't wait for the all servers to be on Wireguard. Maybe try on other devices. I'm using it on my PC. 

 

Thanks for your post! So, what is your experience with regards to download speeds between their "regular" and their "WireGuard servers". Which servers do you access using WireGuard?

Link to post
Share on other sites
kratoscratus1891

Actually I have only 10 mbps now using the prepaid service. I already assumed that using a VPN with decrease the speed but to my surprise it is almost the same but the ping is about 50+ using the SG WireGuard server. I also have Surfshark and it is not comparable on what speed I'm getting at Torguard. As I've said maybe we have different experience. 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...