Jump to content
TorGuard
  • 0
Sign in to follow this  
Guest

Tomato Firmware openvpn?

Rate this question

Question

Guest

DD-wrt sucks. Let's face it.

 

Lot's of us are running tomato firmware.

 

Can you post instructions on how to get it to work?

 

thanks

 

Share this post


Link to post
Share on other sites

11 answers to this question

Recommended Posts

  • 0
Guest

Yes, I'd like to see these as well, I've just signed up for your Proxy service. I use Tomato Firmware and will sign up for VPN shortly.

Share this post


Link to post
Share on other sites
  • 0
TorGuard Admin

We're working on a Tomato walkthrough for OpenVPN and will have up shortly...

Share this post


Link to post
Share on other sites
  • 0
Guest

Any update on this...its been a while, can you guys just release basic settings cuz apparently its taking ages to release the walkthrough.

Share this post


Link to post
Share on other sites
  • 0
Guest

This is some serious S*** ... I only bought this service because I believed it could work with tomato...PLEASE ATTEND TO THIS NONSENSE

Share this post


Link to post
Share on other sites
  • 0
Guest

No,you can't use the same script. Even though the blog entry here mentions tomato: http://torguard.net/blog/custom-dd-wrt-openvpn-routers-torguard-vpn/

 

It doesn't work. I tried using it for the init script and the wan script. This is with the latest Shibby build of TomatoUSB.

 

Then I tried to set up a VPN client using the Tomato GUI. No go there either. Kept getting errors about "no server certificate verification has been enabled" - despite putting in the only certificate I had - the CA cert in the CA cert field.

Share this post


Link to post
Share on other sites
  • 0
deltahotel

I have managed to get it working... Using Tomato v1.28 by Shibby... after you get it all oonfugured, I found it necessary to reboot to make it work. Here's the config I used:

 

Click VPN Tunneling menu, then OpenVPN Client submenu

Choose the Client 1 tab and then Basic tab below

Check Start with WAN if you want to auto-connect whenever your router is online/starts up

Set Interface Type to TUN

Set Protocol to UDP

Set the Server Address/Port to us-east.privateinternetaccess.com (or whichever server you prefer) and port to 1194

Set the Firewall to Automatic

Set Authorization Mode to TLS

Check Username/Password Authentication

Enter Your Username/Password in the boxes that newly appear below the check box

Ensure that the Username Authen. Only box is unchecked

Uncheck Extra HMAC authorization

Check Create NAT on tunnel

Click on the Advanced tab

Set Poll Interval to 0

Uncheck Redirect Internet Traffic

Set Accept DNS configuration to Strict

Set Encryption cipher to Use Default

Set Compression to Adaptive

Set TLS Renegotiation Time to 0

Leave Connection retry as 30

Uncheck Verify server certificate (tls-remote)

In the Custom Configuration textbox, input the following:

persist-key

persist-tun

tls-client

comp-lzo

verb 1

Click on the Keys tab

Paste the contents of ca.crt found in OpenVPN Config Files, into the Certificate Authority text area

Press the Save button before the Start Now button

Share this post


Link to post
Share on other sites
  • 0
Guest

Support chat just confirmed it would be working and provided a link for the dd-wrt walkthrough. So I bought it to find out its not. This ist serious shit!!!

 

Thx Dustin. I'll try out your work. If I cant get it to work I want my money back and I'll switch to HMA vpn.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...