Jump to content
TorGuard
  • 0
yopparaiiii

VPN Client setup via DDWRT Router

Rate this question

Question

yopparaiiii

I am having trouble setting up the vpn client using  dd-wrt firmware router. I've followed this guide. It looks like I got a connection, but I don't have Internet access on any devices connected to the router.
Router: Linksys E4200
DDwrt Firmware: K2.6 (30880)

Setup:
torguard-vpn-client-01.jpg

Connection:
torguard-vpn-client-03.jpg

Log:
torguard-vpn-client-02.jpg

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0
kurisu

What's in your additional config section, and do you have any additional network routes or gateways defined in the firewall script? (Administration, Commands, Command Shell, Commands)

I presume you want to use the Redirect Default Gateway option for devices connecting to the router?

If you SSH to the router and run 

wget -qO- ifconfig.co

(unless you installed cURL via ipkg, in which case "

curl ifconfig.co

what IP address do you see, your ISP IP or a VPN IP? If that works, traceroute to any web site, what path does the traffic take, via tun1 or direct to eth0 gateway?

If it doesn't work, try pinging 8.8.8.8 and 1.1.1.1 through the VPN tunnel, then run traceroute -n xxx.xxx.xxx.xxx them to see what path they take. If that works, it's a DNS resolution issue - check your clients to make sure they are not using static DNS.

 

Clients on the router should be getting DNS settings via DHCP - and so, they should be communicating with DD-WRT for their DNS requests. The router serves DNS requests via DNSMasq service - and DNSMasq should redirect incoming requests through to the VPN-pushed DNS servers when the VPN is connected.

[edit] Just noticed you're running K2.6 - any reason why you're not running a K3 kernel firmware? A while back I read about people upgrading to K3.0 r34578 mega and it was fine, wifi issues eliminated and general performance was better.

Depending on which DD-WRT build or fork you're running, it may be a bug in how DD-WRT sets up DNS when connecting the VPN.

Read the forum thread for more discussion about /tmp/resolv.dnsmasq datestamp issues, a potential bugs in how DD-WRT sets up the VPN connection and checks /tmp/resolv.dnsmasq, plus workarounds to get VPN pushed DNS working - https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=306779

Don't own an E4200 so apologies I can't help further. DD-WRT forums are great for this stuff though and you can't be the first E4200 owner contempating a K3 upgrade... Handy links:

Share this post


Link to post
Share on other sites
  • 0
yopparaiiii

I do not have any firewall setup in the router. All there is in the command shell a startup script.

Startup Script:

sleep 10
sh /jffs/etc/config/wan_ipaddr.startup
ifconfig eth0 txqueuelen 5
wl -i eth1 interference 4
wl -i eth2 interference 4

echo 262144 > /proc/sys/net/core/rmem_max
echo 262144 > /proc/sys/net/core/wmem_max

echo "4096 87380 262144" > /proc/sys/net/ipv4/tcp_rmem
echo "4096 16384 262144" > /proc/sys/net/ipv4/tcp_wmem
echo 1000 > /proc/sys/net/core/netdev_max_backlog
echo 16384 > /proc/sys/net/ipv4/netfilter/ip_conntrack_max
echo 16384 > /sys/module/nf_conntrack/parameters/hashsize

 

wget -qO- ifconfig.co

Does not return any ip address when connected to the vpn. Ping 8.8.8.8 times out as well.
 

I followed Steve's guide setting up the E4200 using the K2.6 firmware. He mentioned in the comment section of this blog that the vpn works with this build by users in the ddwrt forum.
http://www.stevejenkins.com/blog/2013/01/my-cisco-linksys-e4200-dd-wrt-settings-for-max-speed/
 

Additional info: I am behind double nat with no access to the main router. My wan ip address is a public ip address.

Share this post


Link to post
Share on other sites
  • 0
conpaul

Make sure your primary router has VPN pass through enabled.

I have also had to configure the DMZ on the primary router and use the DMZ IP as WAN on DD-WRT.

The DD-WRT guide you have listed does work perfectly, but you do need to follow the entire guide step by step

Make sure you have diabled PPTP IPSEC etc

You need to enable the Open VPN server 

 

 

 

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...