Jump to content
TorGuard
43524_1511348124

Internet connected, but no access till Torguard connected?

Recommended Posts

43524_1511348124

OK, so I have a Lenovo X1 Carbon (4th gen) and it connects to my home (Xfinity through AdvancedTomato on a Netgear R7000) and my parents, (Xfinity, stock R7000) and through some others at work, various work offices, school, etc.  It always connects just fine to whatever wifi, but I have zero Internet access until after I connect Torguard's VPN).  It's really strange since yes, having a VPN always is great, but sometimes at home I don't want to when I'm streaming Netflix or something so I have full bandwidth (and so it doesn't close my browser if it disconnects).

Any ideas on why this is happening?  Also, if I reinstall Windows 10 Pro on the laptop and then use wireless, it's fine.  It only seems to happen after I install and connect Torguard's application to connect.

Share this post


Link to post
Share on other sites
Steve123456

I have this problem too,  It started a few weeks ago and today has degraded to the point that I cannot access any online connection and Torgard won't load. Secondly the  Los Angeles server ALWAYS requires me to continue to resolve server hostname and has been very slow.   I had this for 3 months and my payment is due.  Thirdly, I cannot get to the live bubble helper on my laptop even though it will connect to your website.  

 

Three strikes, Torgard kindly send me uninstallation instructions.  My 3 months are up, I will not be renewing.  Leaving me high and dry with only email or this message board is not cool.

 

Share this post


Link to post
Share on other sites
kurisu

I've used the ticket system through the client area many times, they're usually pretty responsive even on weekends.

I've used OpenVPN UDP and TCP TorGuard for a year with no problems on my Win 10 PC.

Lenovo machines are renowned for shipping with bloatware, and your issue doesn't sound like a TG problem, it sounds like either a TUN adapter conflict or issue, or possibly a firewall/AV issue. What antivirus/security software are you using?

What other troubleshooting have you done on your side? Ran pings or done traceroutes when you lose connectivity to see if the traffic is stopping anywhere in particular? Checked for conflicting software? Tried TCP instead of UDP? (TCP does some TCP-in-TCP 'magic' to avoid issues like packet fragmentation, despite it being less efficient on a totally optimised connection).

The VPN connection grinding slowly to a halt is indicative of a problem with your PC (software or drivers) or your connection, not necessarily the TG server. I use various TG servers in the UK and US, all of which perform reliably. Slightly slower at peak time if you're hammering a download or upload, but still plenty fast (always over 100 mbit/sec).

How does it perform if you run over a wired link? If fine, that points to wifi chipset or driver problems.

Have you booted the machine from a Linux live USB or live CD and set up a VPN connection in Linux to test? That's a harmless way of doing a useful comparison on the same hardware without having to set up dualboot.

 

Also, have you tried other VPN providers? They all use the same underlying approach (build aspects of the OpenVPN client into their own apps and wrap that with their own interface) and so they almost all use the same kind of TUN adapters controlled in the same way.

If you're having problems with one provider, you'll quite possibly have problems with all of them.

Have you done a clean uninstall of the TorGuard app and then reinstalled the latest version? Have you tried installing with the older version of the TUN adapter?

I'd also try OpenConnect and/or Wireguard, both of which are available to you either through the TG client app or by installing a WireGuard client on your PC and following some instructions online (not too tough, and the TG site gives you the crypto details you need to put in on your client).

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...