Jump to content
TorGuard
  • 0

No internet if VPN is connected to server in Mac

Rate this question


DKS

Question

Hi There, 

I am using TorGuard in MacBook Pro and OS is Catalina. There is no internet if VPN is connected. I can connect to server but there is no internet when VPN is connected to server. I have to disconnect TG to get the internet back. However, the TG is working great in my iPhone!! Please suggest me if you have similar me experience and what to change in settings of Mac as well as in TG. I am new in in VPN/TG and your suggestions would be appreciated. 

Thanks,

DS

Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0
On 11/30/2019 at 4:33 PM, DKS said:

Hi There, 

I am using TorGuard in MacBook Pro and OS is Catalina. There is no internet if VPN is connected. I can connect to server but there is no internet when VPN is connected to server. I have to disconnect TG to get the internet back. However, the TG is working great in my iPhone!! Please suggest me if you have similar me experience and what to change in settings of Mac as well as in TG. I am new in in VPN/TG and your suggestions would be appreciated. 

Thanks,

DS

 

Hello,

Please go to more settings --> Network Tab --> Set the DNS as below:

At Application Start: Level3
While establishing: Level3
When VPN is connected: Level3

Restart TG Client and retest.

Link to post
Share on other sites
  • 0
Belidoo

Hi all

I'm having the same issue and tried above suggestion about DNS settings in TorGuard, but no luck. Some more details:

I have two systems with macOS High Sierra (10.13.6) and I'm working with a user account WITHOUT administrator privileges. TorGuard VPN worked fine until I did the following:

- Installed latest security fixes (macOS Security Update 2020-003)

- Upgraded TorGuard client to v3.98.12

(I know I should not have installed two updates at the same time, so I'm unable to tell which exactly introduced the problem ;-( )

Now, on both systems I have no Internet connection when TorGuard VPN is connected. I have not done any deep analysis but it seems that TorGuard cannot update the DNS server settings in the system when launched from within my non-administrator account.

When I launch TorGuard through the command line using elevated administrator privileges in that command line window, but otherwise still under my account without administrator privileges, all works fine and the DNS servers (checked with nslookup) get updated.

When I launch TorGuard from within my non-administrator account, it connects OK, but does not update the DNS servers and hence I have no Internet connection.

I tried various DNS servers in TorGuard configuration, but no luck. Any ideas, any help?

Link to post
Share on other sites
  • 0
user987

I've been having the same issue on Catalina 10.15.5 and have been in touch with support to try to fix it.

After changing the settings per the instructions I'm having about a 60% success rate browsing the web on Firefox and Safari but it's not working at all on Chromium browsers or apps that require internet access.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...