Jump to content
TorGuard
  • 0
Support

TorGuard Client v3.96.1

Rate this question

Question

Support
Release torguard-v3.96.1, 2019-07-23
====================================

* All platforms: Fix crash when "Dedicated IP" is used together with
                "Block the internet when not connected"

Downloads

Share this post


Link to post
Share on other sites

15 answers to this question

Recommended Posts

  • 1
TDog

Is it just me or has the client started acting funky? On one of my systems it would seem to get caught in a loop and take over the machine. I couldn't even bring up the task manager to end the process, a hard shut down was needed more than once. I cleaned every trace of the client out of my machine using an uninstaller and reinstalled. Didn't help right away but today it's passable with one exception (maybe two).

1. There is a huge lag in initial connection. I suspect that's what caused the lock-ups earlier.

2. The client now after a lag asks me to enter log in info that I have already saved. Simply resubmitting that info most times logs me in fairly quickly, sometimes no.

I would also like to say I am a computer professional/ PC Div Manager for many, many years. I have tried all the simple obvious fixes and would like to think I know what I am doing. After all until very recently the client worked like a champ for me.

It's also worthy of note this happens to some extent the same on two different systems of completely different hardware/software configurations on very different networks with nothing in common besides than they are both running Win 10 Pro 64 bit 1903 and the current Torguard client.

Share this post


Link to post
Share on other sites
  • 0
Crumpile

Brand new installation of Windows 10 Pro, zero apps installed except Brave browser. I installed this new VPN client and the wifi connection drops and then the TAP connection resets; it will keep doing this perpetually. Eventually the wifi will reconnect to my router, show internet access, but I can't ping outside my network. DNS appears to be the issue after it appears to have connected. I updated all drivers for every piece of hardware. Fully updated Windows. Reinstalled the VPN app and TAP. Still going through a connection loop. I have been using this app for about 7 years and this is the first major problem I have had like this. I think the new release is super buggy.

Share this post


Link to post
Share on other sites
  • 0
Support
2 hours ago, Crumpile said:

Brand new installation of Windows 10 Pro, zero apps installed except Brave browser. I installed this new VPN client and the wifi connection drops and then the TAP connection resets; it will keep doing this perpetually. Eventually the wifi will reconnect to my router, show internet access, but I can't ping outside my network. DNS appears to be the issue after it appears to have connected. I updated all drivers for every piece of hardware. Fully updated Windows. Reinstalled the VPN app and TAP. Still going through a connection loop. I have been using this app for about 7 years and this is the first major problem I have had like this. I think the new release is super buggy.

 

Hi there,, you wouldn't happen to be using an HP laptop/PC, are you?

Regards

Share this post


Link to post
Share on other sites
  • 0
AC3

on macos 10.14.5, I also experience the lag/spinner when logging in. I thought it was a return of a former issue, but when I let it spin for a bit, it actually logs in.

laptop: macbook pro 2013

Share this post


Link to post
Share on other sites
  • 0
PaymentTypes

Running Windows 10 and constant wait then reconnecting, where as the firefox plugin works. Spoke with support and the usual uninstall and reinstall answer.

It doesnt work, fix it, or remove the download, easy as that.

Share this post


Link to post
Share on other sites
  • 0
Support
5 hours ago, AC3 said:

on macos 10.14.5, I also experience the lag/spinner when logging in. I thought it was a return of a former issue, but when I let it spin for a bit, it actually logs in.

laptop: macbook pro 2013

 

Try the following:

1) Go to more settings --> general tab --> click "restore defaults" and then hit save

2) Delete the Torguard app from the applications folder and empty your trash

3) Remove this folder:   ~/Library/Application Support/VPNetworkLLC

4) Reboot + Reinstall TG Client latest version here https://torguard.net/downloads.php

Let me know how you go.

Share this post


Link to post
Share on other sites
  • 0
Support
4 hours ago, PaymentTypes said:

Running Windows 10 and constant wait then reconnecting, where as the firefox plugin works. Spoke with support and the usual uninstall and reinstall answer.

It doesnt work, fix it, or remove the download, easy as that.

 

There are a number of reasons this may happen, it doesn't mean the issue is a TG issue or a bug, this simply means either you are not able to resolve our hostnames or your local cache is resolving old IP's - go to more settings --> network tab --> hit clean cache and then refresh cache then retest - are you connecting to a specific location or IP?

Share this post


Link to post
Share on other sites
  • 0
Amir

When the new UI for Windows will be released? I read on Twitter  that it will be released very soon. 

Share this post


Link to post
Share on other sites
  • 0
Support
On 8/27/2019 at 2:51 AM, Amir said:

When the new UI for Windows will be released? I read on Twitter  that it will be released very soon. 

 

There is no eta at the minute but i can assure you they are working on it.

Regards

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
TDog
3 hours ago, Support said:

 

There is no eta at the minute but i can assure you they are working on it.

Regards

I am looking forward to seeing this new GUI as well. Please test it thoroughly before it's release or at least let folks it's a Beta if that's the case. Thanks. 

Share this post


Link to post
Share on other sites
  • 0
Amir
On 9/25/2019 at 6:07 PM, TDog said:

I am looking forward to seeing this new GUI as well. Please test it thoroughly before it's release or at least let folks it's a Beta if that's the case. Thanks. 

Me too. I feel it will be out in late October.

Share this post


Link to post
Share on other sites
  • 0
Amir
On 9/25/2019 at 6:07 PM, TDog said:

I am looking forward to seeing this new GUI as well. Please test it thoroughly before it's release or at least let folks it's a Beta if that's the case. Thanks. 

TorGuard told me this in Twitter which made me happy:

Yes, it has been in the pipeline for sometime. We first wanted to finish some internal updates that will greatly expand cross platform capabilities in the coming months. That is now complete so a UX update has been made a priority.

Share this post


Link to post
Share on other sites
  • 0
Amir

Admin, please let me know when the next version released. I stopped checking the wbsite everyday. Thank you!

Share this post


Link to post
Share on other sites
  • 0
Amir

Dear Admin, any update or ETA about the new Windows version? I did a clean installation of my Windows 10 and right now I am using another VPN.

And I am waiting for the next Windows version of TorGuard, so I will install it.

Thank you.

 

Share this post


Link to post
Share on other sites
  • 0
Support
On 11/16/2019 at 1:39 PM, Amir said:

Dear Admin, any update or ETA about the new Windows version? I did a clean installation of my Windows 10 and right now I am using another VPN.

And I am waiting for the next Windows version of TorGuard, so I will install it.

Thank you.

 

 

We are working on it Amir - this won't be a whole complete design change, it will be be a more modern and smoother look though, a bit like our new Android UI.

Regards

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...