Jump to content
TorGuard
Support

TorGuard Chrome VPN Extension 1.3.8

Recommended Posts

Support

Release torguard-chrome-vpn-extension-v1.38, 2019-07-01
====================================

* Ad and Malware Blocking Updates

Updated TorGuard Ad and Malware blocklists

* Logo Change

* Bug fixes

Downloads

Share this post


Link to post
Share on other sites
FLW
On 7/9/2019 at 12:08 AM, Support said:

Release torguard-chrome-vpn-extension-v1.38, 2019-07-01
====================================

* Ad and Malware Blocking Updates

Updated TorGuard Ad and Malware blocklists

* Logo Change

* Bug fixes

Downloads

Once I click on Downloads, then the TorGuard Chrome Extension, I get a 404 error "The requested URL was not found on this server. That’s all we know."

 

Share this post


Link to post
Share on other sites
Support

We know of the problem, Google changed some policies recently but dealing with google is never fast - the changes are made we are just waiting on Google to respond, once they do it will be back online.

Regards

Share this post


Link to post
Share on other sites
MasterDokuro

Is there an eTA on when this will be available again ? 

Hours -- Days -- Weeks -- never ?

Share this post


Link to post
Share on other sites
Support
1 hour ago, MasterDokuro said:

Is there an eTA on when this will be available again ? 

Hours -- Days -- Weeks -- never ?

 

We can't tell you how long google will take to review it - once they do it will be back online.

Share this post


Link to post
Share on other sites
E.A. van Dijk

Why am I not surprised at all that the chrome extension isn't available? Some old experiences, but mostly recent developments at Torguard, forces me to make use of services from a 2nd VPN provider. My subscription at TG ends in 2,5 months and it's unlikely that I'll let it continue. That's a shame, because when all is working TG is very good. Unfortunately not all is working all the time. The basics for a good service are all there but then all those little weird decisions are being made creating a maze instead of a user-friendly environment. Not to mention the last upgrade process.. that's how people end up in straight jackets.

Well, I never rule out all options but for now I'd rather pay two subscriptions then rely solely on TG.

Share this post


Link to post
Share on other sites
Support
9 hours ago, E.A. van Dijk said:

Why am I not surprised at all that the chrome extension isn't available? Some old experiences, but mostly recent developments at Torguard, forces me to make use of services from a 2nd VPN provider. My subscription at TG ends in 2,5 months and it's unlikely that I'll let it continue. That's a shame, because when all is working TG is very good. Unfortunately not all is working all the time. The basics for a good service are all there but then all those little weird decisions are being made creating a maze instead of a user-friendly environment. Not to mention the last upgrade process.. that's how people end up in straight jackets.

Well, I never rule out all options but for now I'd rather pay two subscriptions then rely solely on TG.

 

Hey there, the Chrome Extension will be back online shortly, the only reason why it has been offline as long is Google Engineers take so long to reply, they actually said it was a mistake and they are speaking to another department to bring the extension online. Can i ask what is not working for you or you are having issues with?

Regards

Share this post


Link to post
Share on other sites
Support
On 8/12/2019 at 11:56 AM, Support said:

 

Hey there, the Chrome Extension will be back online shortly, the only reason why it has been offline as long is Google Engineers take so long to reply, they actually said it was a mistake and they are speaking to another department to bring the extension online. Can i ask what is not working for you or you are having issues with?

Regards

 

This is now back online everyone, sorry for the delay!

Share this post


Link to post
Share on other sites
otto38dd

Hi,

I am in China and the Chrome extension works great here.  A couple of questions: 

1.  The Chrome extension is actually working better here in China than the Windows client.  I see that, while config options are limited, the extension uses ports not available in the client.  How can I add those ports to the client?

2.  What other differences are there between the extension config and the client config besides ports?

Thanks,

otto38dd

Share this post


Link to post
Share on other sites
Support
On 9/23/2019 at 3:03 PM, otto38dd said:

Hi,

I am in China and the Chrome extension works great here.  A couple of questions: 

1.  The Chrome extension is actually working better here in China than the Windows client.  I see that, while config options are limited, the extension uses ports not available in the client.  How can I add those ports to the client?

2.  What other differences are there between the extension config and the client config besides ports?

Thanks,

otto38dd

 

Hello,

1) They both operate on different ports, you can't use proxy ports with OpenVPN and vice versa

2) The extension uses SSL based proxies while the software uses OpenVPN, OpenVPN is heavily targeted in China so it has to be run alongside stunnel, stealth or shadowsocks in most cases.

Regards

Share this post


Link to post
Share on other sites
Newguy2020

I can get online via the windows client, however the chrome extension fails login?

Share this post


Link to post
Share on other sites
Support
5 hours ago, Newguy2020 said:

I can get online via the windows client, however the chrome extension fails login?

 

It could be to do with an AV likely or a wrong user/pass - please double check your username and password if those are correct then make sure your AV doesn't have a mail module that blocks those ports, in our extension we use some SSL mail ports to make it easier to get out of some networks, unfortunately some AV mail modules tend to block them and the symptom of that is a login failed error .

Regards

Share this post


Link to post
Share on other sites
Newguy2020

I have verified my user/password and they work to login both the website and windows client.

I am only using windows defender for AV at the moment. Firewall rules are default.

Share this post


Link to post
Share on other sites
Support
12 hours ago, Newguy2020 said:

I have verified my user/password and they work to login both the website and windows client.

I am only using windows defender for AV at the moment. Firewall rules are default.

 

Please open a support ticket, im not able to reproduce, a login error message is normally always something blocking the connecting port or simply wrong credentials.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...