Jump to content
TorGuard
  • 0

Client freezes on connecting (v3.95.0 macOS)

Rate this question


Poseidon

Question

Poseidon

Every time the client is connecting to a server the client freezes for upwards of a minute, the icon in the menu bar also causes a spinning beach ball when hovered over. On it's own this is annoying and it's bad enough that there's a systemwide cut off from the internet for multiple minutes because TorGuard is trying to connect(?) where one would expect a smooth transition that doesn't take you out of the workflow for 5 minutes, since it being a hassle now causes me to not wanna go through the hassle and avoid using my VPN connection. 

It really starts to become a problem, however, when the bugginess of it all causes SystemUIServer to freeze up and the whole menubar and apps that reside in it are unavailable and you're basically forced to reboot since killing SystemUIServer in such a state doesn't spawn a new process.  

Is there a way to prevent this from happening or could it at least be a priority in a future update? The actual service that TorGuard provides (i.e. the servers and the actual VPN connection) are great as far as I'm concerned especially when taking the low cost in consideration but everything beyond the actual technical service feel kinda lacklustre and the client is the main culprit when it comes to that feeling. Am I really left to use a third party VPN client to enjoy these services without hassle? 

Weirdly enough I can't remember it being like this when I started using TorGuard, rather this is something that started happening in the last couple of versions of the client I feel. Anyways I've installed the client on a freshly initialised macbook, I've followed the steps provided here since I thought it might benefit me and it did mitigate the issue somewhat (i.e. instead of it freezing for 3-5 minutes, it's reduced to about 2 minutes give or take). 

But I'd like to see if there's a solution from TorGuard's side and honestly I'm curious if I'm the only one affected by this since I can't seem to find much similar issues here on the forum. My sub is up next month and like I've said, I think the value proposition is very strong with TorGuard when it comes to the actual technical service but where I used to connect to a VPN on the regular multiple times a day in the past, I now tend to avoid going through the hassle for the most time and have barely touched the service in the last months and to me that's a bad sign so if this keeps up I might have to switch to a different VPN provider. I mean it's not like I'm looking for bells and whistles, but the act of connecting should be smooth and easy imho.

Link to post
Share on other sites

11 answers to this question

Recommended Posts

  • 0

Have you made a support request?  Maybe it is something in your configuration of the client (lots of tick boxes whose meaning is not always obvious).  I have not had this problem.

Link to post
Share on other sites
  • 0

i have the same issues with my mac, but not on windows. literally takes upwards of 5 minutes to connect, all the while saying its not responding in the activity monitor. ver 10.13.6. is the mac build stable? if i cant get it fixed, i'll be forced to go with a lousier vpn, which id rather not

Link to post
Share on other sites
  • 0
DONTPOKEME

I have the same issue on mac. Probably Torguard should change the App framework to electron or some other best framework other than old QT framework. Its really difficult and hard to use Torguard client in Mac. I tried all the troubleshooting steps. It takes more than 5 minutes to start the torguard client and connect.

Link to post
Share on other sites
  • 0
Support
23 minutes ago, DONTPOKEME said:

I have the same issue on mac. Probably Torguard should change the App framework to electron or some other best framework other than old QT framework. Its really difficult and hard to use Torguard client in Mac. I tried all the troubleshooting steps. It takes more than 5 minutes to start the torguard client and connect.

 

Hey there - are you running the very latest build - by chance?

Link to post
Share on other sites
  • 0
DONTPOKEME

Yes I did. Now I am  using 4.2.0 latest version. Still no luck. UI freezes connects after 5 mins. If I click show/hide its a dream. Could you please rewrite the client with some latest framework to avoid these issues?  QT client kills me seriously. TorGuard is the best service but trust me the TorGuard Client killing your business. People always look at the client. It's the ultimate front end ui which represents TorGuard. Please fix this. Thank you. 

Link to post
Share on other sites
  • 0
19807409
4 minutes ago, DONTPOKEME said:

Yes I did. Now I am  using 4.2.0 latest version. Still no luck. UI freezes connects after 5 mins. If I click show/hide its a dream. Could you please rewrite the client with some latest framework to avoid these issues?  QT client kills me seriously. TorGuard is the best service but trust me the TorGuard Client killing your business. People always look at the client. It's the ultimate front end ui which represents TorGuard. Please fix this. Thank you. 

I agree that from perspective of businnes tg client needs to be stable. I would disagree on few points, one of them would be that people look always at the client, some do not, for some it is more important if torguard does run with open source clients, mainly as there is none vpn provider offering a client for all architectures and users are dependant on it. Some vpn providers use exactly that for their marketing, simply claiming that opensource clients can be used and are allowed to be used. From that perspective, TorGuard offers one of best services, for different people and different use cases where if you run into some issue like that there is no client for your platform, then you are still able to use torguard and are not forced to move to another vpn just because your architecture was not important for the company to take in mind.

Did you try disabling lookup server hostname before connecting (if that is available on mac client)? grafik.png

Do you clearly see that the issue is QT and where? I can see no issues at all on linux supported platforms as well as I cant for windows, maybe this issue is specific for mac os? How do you know that you waiting for minutes is caused by QT? During it tells you that you are reconnecting, did you try to check in terminal if you are connected? As if QT crashed you would clearly see it in logs as well it wouldnt probably update the state after 5 minutes like you state? If it tells you after 5 minutes that you are connected, I doubt it is QT which was connecting, QT is just a GUI, it is probably the code/scripts which needs to be adapted, I doubt it has anything to do with QT unless somebody shows logs where it clearly is shown, then torguard could also fix it would be my opinion, but yeah, torguard devs probably know anyway what the issue could be as its them who released it.

Link to post
Share on other sites
  • 0
DONTPOKEME

Hi My Friend,

It not working only in Mac OS. I have tested this in almost all OS flavors [Windows, Linux and Unix] and working fine. Tried all the troubleshooting steps but no luck. In Mac it takes 27 mins to refresh the dns cache. Connects after 5 min. Please do let me know which logs you want. I can share you. Most  of my community friends are using TorGuard. Whoever uses Mac, they all have the same issue. 

Link to post
Share on other sites
  • 0
Support
1 hour ago, DONTPOKEME said:

Hi My Friend,

It not working only in Mac OS. I have tested this in almost all OS flavors [Windows, Linux and Unix] and working fine. Tried all the troubleshooting steps but no luck. In Mac it takes 27 mins to refresh the dns cache. Connects after 5 min. Please do let me know which logs you want. I can share you. Most  of my community friends are using TorGuard. Whoever uses Mac, they all have the same issue. 

 

Hello,

Sorry we don't really get a lot of complaints from users on Mac, I use it myself - normally if there is any delay in the connect process or freeze in the UI theres a good reason for it - I myself don't see any such delays, openconnect can occasionally take a little bit but other than that its fine.

Enable debugging and restart the app, recreate your problem, the delay or a freeze, then before closing the app grab the log and send to [email protected] - thanks

Link to post
Share on other sites
  • 0
19807409
2 hours ago, DONTPOKEME said:

Hi My Friend,

It not working only in Mac OS. I have tested this in almost all OS flavors [Windows, Linux and Unix] and working fine. Tried all the troubleshooting steps but no luck. In Mac it takes 27 mins to refresh the dns cache. Connects after 5 min. Please do let me know which logs you want. I can share you. Most  of my community friends are using TorGuard. Whoever uses Mac, they all have the same issue. 

hello,

if you experience it anyway on all operating systems and different hardware, all same issue, reproduceable, then to addition of support's explanation of which log would be useful, you maybe should check the network in which you perform it. You said all your friends have that issue, but nobody reports it and other users on linux, windows and mac can not reproduce the issue. It could be a student house or something similar, you did not mention what connection you have, where you all are on a same network experiencing same issue. But like I said before, on linux there is no issues and no errors with QT at all, I at least cant confirm any. If your log file shows no errors, then you probably should check your network settings like dns, maybe low priority ports and so on...

Link to post
Share on other sites
  • 0
DONTPOKEME

Wow! I love TorGuard. I sent the logs and SysAdmin fixed the issue on their servers. Now the Client Works like a charm. Thank you so much guys. We Love you. Great job. Way to go my friends. 

  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...