Jump to content
TorGuard
  • 0

Deluge and multiple proxy settings

Rate this question


Guest

Question

I am running Deluge 1.3.6 on a headless Ubuntu 13.10 server and connecting to it via a Windows client and/or browser.

 

In the Deluge proxy setup documentation, it says to fill in all four proxy settings (peer, web seed, tracket, and DHT) with the same information.

 

If I do this, however, my deluged service crashes shortly after adding a torrent file. After much research and experimentation, I have it working if I ONLY fill in the Tracker section with my TorGuard credentials, leaving the others set to None.

 

From what I've read, the version of libtorrent underneath Deluge will use the one setting for ALL of them. Checking my IP with checkmytorrentip.com and torguard.net/checkmytorrentipaddress.php seems to confirm the proxy is working, but I just wanted to ask and confirm that even though I don't have the Peer, Web Seed, and DHT proxy settings set up in Deluge, my traffic is still going through the TorGuard proxy and not leaking anywhere.

 

Any ideas/suggestions? Thanks.

Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

Hey there

 

This means only tracker communication is proxied, no peers or DHT which leaves you wide open.

 

Does the checkmytorrentip torrent show the proxy IP ? what version of libtorrent are you running ? we recommend 016 +

 

Regards

 

Link to post
Share on other sites
  • 0

Ok that version should be fine with UDP i would imagine - have you done any debugging, checking logs to see if theres any clues as to why its crashing ?

 

Regards

Link to post
Share on other sites
  • 0

Not sure what I did but I kept playing around with the settings and now I have all four proxy settings set on the daemon (using the IP address, not the DNS name of the proxy server) and it seems to be working.

Link to post
Share on other sites
  • 0

I have the same setup and can't get the proxy to work it seems like it crashes my whole system when i add a magnet link in. I have been reading there is a problem with libtorrent0.16 which is a deluge dependency and i have been trying for 2 days to get it working, how were yu able to get it working?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...