Jump to content
TorGuard
  • 0
Mark Eagles

Slow connecting to any VPN Server

Rate this question

Question

Mark Eagles

Over the past couple of days i have been experiancing this warning when connecting to and server via the windows client "connecting to torguard is taking unusually long please check your firewall" , nothing has changed my end , as in network settings / windows etc. Once it is connected the speed grinds to a halt.

 

Now if i use OpenVPN client its ok connection speed is good and bandwidth is also good.

I  have reinstalled the windows software and also updated the TAP v9 driver too but the problem still persists

 

Mark

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0
DaLumberJack

I have been getting the same error lately. Not sure why or what has changed. Also did the same as you in regards to uninstalling everything and performing a fresh install along with making sure the drivers were up to date. 

Also made sure torguard had a clear path through my firewall, but still have the same error. 

Not sure what the problem is at this point. 

Share this post


Link to post
Share on other sites
  • 0
klepp0906

yea, i have used torguard for many many months with the same exact ping.   ~19ms   As of a few days ago, best i can achieve anywhere is 40ms.    Not sure what changed, if its a weather thing or what.   

ive just jostled every setting there is to jostle.  Pings are dramatically worse now.   To chicago servers anyhow. 

Share this post


Link to post
Share on other sites
  • 0
Support
On 2/10/2019 at 11:58 AM, Mark Eagles said:

Over the past couple of days i have been experiancing this warning when connecting to and server via the windows client "connecting to torguard is taking unusually long please check your firewall" , nothing has changed my end , as in network settings / windows etc. Once it is connected the speed grinds to a halt.

 

Now if i use OpenVPN client its ok connection speed is good and bandwidth is also good.

I  have reinstalled the windows software and also updated the TAP v9 driver too but the problem still persists

 

Mark

 

Are you still seeing this problem, Mark? remember that the OpenVPN client will use the same TAP driver as TG so they could be fighting over the TAP, can you remove the OpenVPN default client, reinstall TG and retest - follow these instructions below for a clean install:

1) Uninstall all TAP drivers, go to  >> Control Panel >> System and Security >> System >> Device Manager - Scroll down to Network Adapters, right-click the TAP drivers and uninstall them, deleting the driver too when asked

2) Go to more settings --> general tab --> click "restore defaults" and then hit save

3) Delete the following folder >> C:\Users\user\AppData\Local\VPNetworkLLC renaming "user" to your OS account name.

4) Open Regedit and delete the following key: HKEY_CURRENT_USER\Software\VPNetworkLLC

5) Reboot (important) and then re-download and install the latest build from here https://torguard.net/downloads.php

Let me know how you go.

On 2/17/2019 at 6:29 PM, DaLumberJack said:

I have been getting the same error lately. Not sure why or what has changed. Also did the same as you in regards to uninstalling everything and performing a fresh install along with making sure the drivers were up to date. 

Also made sure torguard had a clear path through my firewall, but still have the same error. 

Not sure what the problem is at this point. 

 

Please try above and report back.

On 2/24/2019 at 11:58 PM, klepp0906 said:

yea, i have used torguard for many many months with the same exact ping.   ~19ms   As of a few days ago, best i can achieve anywhere is 40ms.    Not sure what changed, if its a weather thing or what.   

ive just jostled every setting there is to jostle.  Pings are dramatically worse now.   To chicago servers anyhow. 

 

I would suggest open a support ticket in regards to latency, there could be so many different things that cause a rise in latency.

Regards

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...