Jump to content
  • 0

[solved] Windows 10 with TorGuard client - slow DNS resolution

Rate this question


I've been experimenting since setting up my TG account. Something that's puzzling me is that, whatever DNS setting I choose (pushed DNS, VPN DNS, Google, OpenDNS, CloudFlare...), initial DNS resolution for domains is really slow after the VPN comes up. I mean, 10-15 seconds slow. Once it's resolved once, it's fine - but until then, wow, it's so slow. So as you can imagine, loading pretty much any web site takes a lot longer than it should with all the queries for various domains and third-party hosted content.

Disconnect from the VPN and - hey presto - DNS is instantaneous again.

I also have a NordVPN account. DNS resolution through their network (using their own DNS solution) was always as fast as my ISP's (and On my Android device however, DNS resolution is normal - as it is direct.

Is this a quirk of TorGuard's design of their VPN client, is it an oddity of Windows 10 - which is perhaps peculiar to just my computer? - or has anyone else experienced this and identified a reason for it happening?

Share this post

Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Surprisingly I found this discussed elsewhere - some AirVPN users were having the same problem.

Turns out, DNS queries were still try to go out direct through my ethernet adapter, despite being connected to the VPN. I have a manual interface metric set on my ethernet adapter as I also have wifi on this device which I occasionally use (normally it's completely disconnected from a network).

As soon as I set the interface metric slightly higher than the TorGuard VPN TAP adapter (in each adapter's IPv4 settings) DNS queries while VPNed began to respond instantly.

https://airvpn.org/topic/20812-very-very-slow-dns-lookup/ discusses this and provides the steps to fix.

This may be a bug in how TorGuard implements the TAP adapter? NordVPN connections don't have this problem.

I've also noticed I can still connect to my machine directly via its ISP IP address and a predefined port forward when connected over TorGuard, whereas when connected via NordVPN, it stops responding to WAN requests on its ISP IP entirely.

Share this post

Link to post
Share on other sites
  • 0
21 hours ago, JessiTom said:

isnt there a setting like "block outside dns" or "prevent dns leak" inside the app ? 


Yep, already enabled - didn't seem to stop the OS attempting to route DNS via the physical interface while its metric (previously manually set due to my local network configuration) was lower than the VPN adapter. Setting the ethernet interface's metric slightly higher, then manually setting the TorGuard TAP adapter to a lower value instantly solved the problem. Appears to be a bug in TG's implementation.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now