Jump to content
TorGuard
  • 0
Cerealconyoghurt

Port Forward doubt

Rate this question

Question

Cerealconyoghurt

Hi,

I have opened an IP/Port following the Port Management instruction, and in the dashboard, everything seems ok (Port Forward IPs)

But when I test the port in any web Open Port Check Tool the IP/Port, the outcome is "blocked"

Am I doing something wrong?

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0
kurisu

I had some issues earlier but support live chat helped me out.

The app installed with some default settings which may not be optimal for port forwarding, not sure. Support recommended these changes:

Quote

Please click more Settings->  Network on the Torguard VPN app
Check Webrtc leak prevent and IPV6  leak prevent boxes
Uncheck” Seamless reconnect”
Uncheck the “block internet when not connected” box
Uncheck the “block outside DNS” box
Check “Refresh DNS cache upon connect box” and click “ Clean Cache” next to it
Uncheck “Look up server hostname before connecting”
Locate three drop downs under the " use these nameservers" section
Choose Google under all three of them one by one
Choose DNS state Recovery as- Auto recover
Find out Set System DNS option at bottom of page and set as Google
Click Save and restart App first
Try to Connect with tunnel type Open VPN , Cipher as AES 128 cbc, Port 1912 and protocol as UDP

 

I was already connecting with OpenVPN over UDP but with a stronger cipher and a different port. I didn't modify my TorGuard DNS settings (just using DHCP and VPN-pushed once connected, instead of Google for everything). I did however uncheck 'Seamless Reconnect' (what does that do?) and I also checked WebRTC Leak Prevent. IPv6 Leak Prevent was already checked.

I'd already added my desired VPN IP as a custom server in the TG app preferences, be sure to do that. If you want to test, you can connect to a country server and 'pin' its IP (click the pushpin next to the public IP once connected, then use that for your port forward request - set up a custom server if all works after a reconnect.)

I also deleted and remade my port forward request in the control panel. Mine was a combined TCP and UDP one, I remade it for port 1912 on my chosen VPN IP. I'd already tried port 1194 and 1195 without success.

 

Not entirely sure what made it work in the end - I should do more testing in future to figure it out. I guess support recommend I use a simpler cipher to avoid any session setup problems, I wouldn't have thought that would make a difference. I would be interested to see if port forwards only work if they are requested, and you connect, via port 1912.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
kurisu

Interim further testing indicates you need to connect to your chosen VPN server on port 1912 for port forwarding to work - despite being able to choose from all connecting ports (1194, 1195 etc) for establishing your VPN on the port forwarding setup form.

Obviously you can choose any unused port to forward. Don't forget you'll likely need to forward the same port as both TCP and UDP for torrenting.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×