Jump to content
TorGuard
  • 0
SimonC

OpenVPN on RPi not bypassing geoblocks

Rate this question

Question

SimonC

Hi,

I've set up Torguard OpenVPN on a Raspberry Pi (running the current Raspbian Stretch OS) using the "Method 2" suggested in the Knowledge base (https://torguard.net/knowledgebase.php?action=displayarticle&id=174).

I've set up to use the USA-LA UDP profile and it all looks okay....when I check with whatismyipaddress.com it dutifully tells me that my IP is in LA.

But...when I try to access magnetdl.com website, I get a message that this has been blocked by the Australian government.  I don't understand why I'm getting that error if the VPN is correctly set up.

I don't get that error when I try to access that website using my windows or android devices (with the Torguard client activated) on the same home network.

Has anyone else experienced a similar issue?  Any suggestions on what I may have set up incorrectly?

 

Thanks in advance.

 

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0
Support
On 10/12/2018 at 3:29 AM, SimonC said:

Hi,

I've set up Torguard OpenVPN on a Raspberry Pi (running the current Raspbian Stretch OS) using the "Method 2" suggested in the Knowledge base (https://torguard.net/knowledgebase.php?action=displayarticle&id=174).

I've set up to use the USA-LA UDP profile and it all looks okay....when I check with whatismyipaddress.com it dutifully tells me that my IP is in LA.

But...when I try to access magnetdl.com website, I get a message that this has been blocked by the Australian government.  I don't understand why I'm getting that error if the VPN is correctly set up.

I don't get that error when I try to access that website using my windows or android devices (with the Torguard client activated) on the same home network.

Has anyone else experienced a similar issue?  Any suggestions on what I may have set up incorrectly?

 

Thanks in advance.

 

 

 Hi Simon, 

Did you make sure to check to see if you're leaking any IPv6 address while connected to the VPN on your Pi?

Regards

Share this post


Link to post
Share on other sites
  • 0
SimonC

Based on a Google search on how to disable ipv6, I've added the line:

blacklist ipv6

to the file /etc/modprobe.d/ipv6.conf

but it seems to make no difference.

How would I tell if there is ipv6 leakage?  How do I stop it?

Share this post


Link to post
Share on other sites
  • 0
Support
On 10/28/2018 at 1:08 AM, SimonC said:

Based on a Google search on how to disable ipv6, I've added the line:

blacklist ipv6

to the file /etc/modprobe.d/ipv6.conf

but it seems to make no difference.

How would I tell if there is ipv6 leakage?  How do I stop it?

 

Try the below command:

ping6 ipv6.google.com

What does this produce?

Regards

Share this post


Link to post
Share on other sites
  • 0
SimonC

Hi,

I've implemented blacklist of ipv6 on my Pi, and turned off ipv6 on my modem/gateway/router.

ping6 ipv6.google.com on the Pi now produces the response "ping: socket: Address family not supported by protocol"

I've also checked with ipv6leak.com which suggests that ipv6 is not being leaked.

However, dnsleak.com reports that my dns might be leaking....next step is to understand that and try to stop it.


 

Share this post


Link to post
Share on other sites
  • 0
Support
49 minutes ago, SimonC said:

Hi,

I've implemented blacklist of ipv6 on my Pi, and turned off ipv6 on my modem/gateway/router.

ping6 ipv6.google.com on the Pi now produces the response "ping: socket: Address family not supported by protocol"

I've also checked with ipv6leak.com which suggests that ipv6 is not being leaked.

However, dnsleak.com reports that my dns might be leaking....next step is to understand that and try to stop it.


 

 

Ok, are you using iptables as your firewall?

Share this post


Link to post
Share on other sites
  • 0
SimonC

HI,

Sorry, I'm not sure what iptables are.

I'm on a home LAN behind a "modem" that has a firewall function (to allow all outbound connections, but silently ignore unknown incoming connection requests). 

My Windows and Android devices using TorGuard application manage through that.

The "tutorial" to set up Torguard on a Raspberry Pi didn't say anything about needing to set up or modify iptables.

Thanks for your help and support through this process!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×