Jump to content
  • 0

Get Plex Remote Access to work with TorGuard App

Rate this question



This past week I have been emailing back and for support. I've tried doing what they've asked. Nothing is working. I feel like I'm describing my scenario a bunch of times over and over again. Hopefully someone knows what to do because I don't want to cancel service. I like the dedicated IP and custom ports

There is two ways I can get Plex to work.


If I use PIA VPN with their Port Forwarding service off of my phone to my PC. Plex remote access works


If I use PIA VPN without Port Forwarding and use TorGuard client on PC with dedicated ip with Port Forwarding. Plex remote access works

What I've tried and doesn't work:

-TorGuard app shared IP port forward 32400 to PC running Client dedicated IP port forward 32400

-TorGuard app dedicated IP port forward 32400 to PC running Client shared IP port forward 32400

-TorGuard app dedicated IP  port forward 

-TorGuard app shared IP port forward

If I use TorGuard app and Client. I do get open ports using portchecker.xx. But Plex still doesn't work

What I don't get is why PIA will work and TorGuard won't just using my phone

I do not want to use a second vpn to get Plex remote access to work


Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Hello itsj0n89,


I've been having exactly the same problem. I'm using Linux, although the solution should be the same.


First make sure you are using a static ip openvpn connection from torguard. no pia. For example


Second, request port forwards for both udp:32400 and tcp:32400.


Third, the bit that i hand't done to make the whole thing work. Go into your routers config menu. Where you'd normally set port forwards, make sure you specify a source ip. In this case, with the port 32400. Next make sure that route is pointing at your plex box on your internal network. on port 32400 for example.


This how i have gotten this working. So far so good.

Link to comment
Share on other sites

  • 0

I was also having issues with getting plex to allow access from outside my local network and I had port forwarding set up with torguard (website).  The trick to finally getting it to work was to request both TCP AND UDP port 32400 for the given IP address that I have pinned for my torguard server of choice.  Originally I only had UDP requested because I was using UDP protocol but plex wants BOTH ports.

After that, no problem at all.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...