Jump to content
TorGuard
  • 0
Sign in to follow this  
Zima

VPN through WLAN on OPENWRT router with isolated LAN/WLAN

Rate this question

Question

Zima

Hi!

I have following setup. The main idea: Connect to VPN trough special WiFi spot if i need to do something special.
Next upgrade: Add Tor and Privoxy service and connect from Home LAN, trough special Privoxy port.


             | INTERNET
             | external IP    
             | 
|------------+-------------------------|
|     ISP GPON ROUTER    |
|     192.168.0.1                 |      Comment: i CAN forward ports,
|     NAT,                              |      change IP of internal network,
|     provider controlled    |      change a name of SSID  
|     firewall                         |      can't check any rules on
|------------+------------------------|      this firewall and can't trust fully

               |
               |              wlan0-1 WiFi AP for VPN     
|------------+-----------------------+-----------------------
|       eth1 (wan)                |       10.55.0.0/24 (VPN lan)
|      192.169.0.45             |       network, dhcp
|                                           |       VPN options
|     OPENWRT router       |       TUN
|       firewall                       |       subnet
|    OpenVPN client           |
|        Privoxy                      |       
|          Tor                           |        192.168.1.0/24 (HOME lan)
|                                           |       network, dhcp,
|                                br-lan+-----------------------
|    192.168.1.1                 |        internet access through main router w/o VPN
|                                          | 
|--------------------------------------|

OpenVPN is working with TorGuard and it's ok. BUT...
Starting OpenVPN droping the all connection to internet, from HOME lan users, cos of OpenVPN changing the routing table.
Then i'm using option -
    option pull-filter 'ignore redirect-gateway'
- it's working. But i still can't create valid routing for working VPN and HOME lan at the SAME time.

Routing table with OpenVPN started 
default         10.33.0.5       128.0.0.0       UG    0      0        0 tun0
default         192.168.0.1     0.0.0.0         UG    0      0        0 eth1
10.33.0.1       10.33.0.5       255.255.255.255 UGH   0      0        0 tun0
10.33.0.5       *               255.255.255.255 UH    0      0        0 tun0
10.55.0.0       *               255.255.255.0   U     0      0        0 wlan0-1
88.202.177.231  192.168.0.1     255.255.255.255 UGH   0      0        0 eth1
128.0.0.0       10.33.0.5       128.0.0.0       UG    0      0        0 tun0
192.168.0.0     *               255.255.255.0   U     0      0        0 eth1
192.168.1.0     *               255.255.255.0   U     0      0        0 br-lan

How i can solve this?


 

Share this post


Link to post
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×