Jump to content
TorGuard
  • 0
LNK

Invalid Port error when using torguard

Rate this question

Question

LNK

I have one tracker which gives me an 'invalid port' error when I run qbittorrent through Torguard, but works fine when i uses proxy=none (so not through Torguard). I have 300+ torrents from various trackers that don't care and work fine with qbittorrent through Torguard, so my port (63036) seems to be open and generally working fine. Does torguard block certain ports that the tracker might be expecting? How could I find out / resolve this? Support folks at the tracker are less than supportive. Torrent uses an https url to connect

It's just a bit weird that it's one particular tracker that won't play - other trackers, including other https trackers, are fine.

Running through proxy.torguard.org on ports 1085 and 1090

Win 8.1, qbittorrent 4.12

 

Grateful for any good thoughts.

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0
Support

The tracker responds with this message when a peer sends an HTTP request to the tracker that is missing a port parameter, or that has an invalid port parameter. If everything is working fine with your torrent client and you're able to download the torrent, then the error can be safely ignored.

It's possible that the qbittorrent client is sending a test request to the tracker that is missing the port parameter before it sends a real request. No idea why it would do this, but the warning is just informational.

Regards

Share this post


Link to post
Share on other sites
  • 0
LNK

Hi, thanks for taking the time to answer.

I wondered about a missing port on the tracker url as well - I've seen it on other trackers. But https trackers from 'sister' websites also don't have a port number on their urls and they connect fine. The trouble is, for this one tracker, I can't connect to it and it won't download. Take it out of Torguard and it does; inside torguard and it just sits and sulks.

With the help of your fellow support staff (Mike) and your chat agent (Jorden), I've played with options, checked the client and the proxy, flipped it from a socks5 to an http proxy, all to no avail. It just doesn't seem to like proxies of any flavour. I'm not sure if there is a way to have a proxy that doesn't appear to be a proxy and try and fool it that way, so that it starts working.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×