Jump to content
TorGuard
  • 0

Pfsense + Stunnel?

Rate this question


d4rk5oul

Question

Is it possible to get torguard working in PFSense with Stunnel?

 

Or some other way to stop the constant Authenticate/Decrypt packet error’s I get which reduces the connection to a crawl when I use UDP on a Virgin media connection?

 

I’ve found using TCP stops the errors but the speed is then abysmal. If I use the torguard client with stunnel enabled however the speeds improve. The only problem is I need stunnel working on pfsense not the client.

 

Any help appreciated.

Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Hi,

It seems they removed stunnel in newer versions of pfsense , but there are some guides on how to install and use it manually as per this thread: https://forum.pfsense.org/index.php?topic=109873.0

In regards to the  Authenticate/Decrypt packet error, it could be a configuration issue - can you PM me screenshots of your OpenVPN client setup?

Regards

Link to post
Share on other sites
  • 0

Thanks for the offer but i think I've sorted everything out now. For some reason the client only went fast when using TCP if the port was 1212 with STunnel enabled. Checking the site/forums and the rest of the internet didn't say how to translate these requirements to pfsense.

However after a number of days fiddling i've found your normal TCP connection when setup on pfsense is a actually faster than with the clients Stunnel and port 1212 enabled. The mistake i made was initially only testing the connections out on the client and then trying to make the only one that was fast work in pfsense.

Been trying a number of VPN providers out this last week and they all gave really bad UDP connections, including you. After a lot of faffing about i concluded it was a virgin media problem and they have something running on my connection that results in the UDP packets getting messed up randomly from time to time resulting in around 2MB/s speeds and the Authenticate/Decrypt packet error’s.

So with UDP out I've been trying to get TCP working. The problem i had with TCP was that standard TCP speeds ranged from 8MB/s to 23MB/s on all providers including you, even after i'd fiddled with the settings in the client.

However when i simply tried your standard TCP connection in pfsense I finally got something close to full speed of 40+MB/s. Makes me wonder what you've done different that allows your standard TCP to work as fast as it should. I have a feeling it might be because you have more up-to-date servers or something.

So in case anyone else is looking at this and are getting Authenticate/Decrypt packet error’s on virgin media with pfsense. First stop using UDP. Second don't just test with the client. Try the various servers/ports out in pfsense itself as well before causing yourself pain and suffering of trying to get Stunnel to work in it. For some reason the client is a lot slower when using TCP then pfsense is. Or at least that is my current experience.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...