Jump to content
TorGuard
  • 0
Sign in to follow this  
noone

OpenVPN Command Line Questions [Solved]

Rate this question

Question

noone

I am running Debian Jessie and have followed the guide for installing openvpn and the TorGuard conf files posted here: https://torguard.net/knowledgebase.php?action=displayarticle&id=32

1) All goes well up through connecting, but after the connection is made, my terminal session is not freed for additional tasks - it ends here...

Thu Jan 11 18:46:13 2018 Initialization Sequence Completed

...and control is not returned.  If I press Ctrl-C to regain control, it kills the openvpn session. 

2) While the above is running, if I open a new terminal window and use 'sudo service openvpn start or stop or restart' as indicated in the above post, none of the options seem to do anything at all.  After running 'service openvpn stop' for example, openvpn is still shown as running via 'ps ax | grep openvpn'.

3) The only way to stop openvpn that I've found is to press Ctrl-C in the "lost" terminal session.  After doing so, my terminal session no longer behaves properly, e.g. pressing enter gets a new prompt on the same line as the current prompt, and characters typed do not appear, but are processed when Enter is pressed.

I do not see anything indicating that others have these issues, and so have not found any solutions for them either.  Any assistance in getting things to behave "properly" is appreciated.

-------

Updated 1/13/18:

The problem lies in the syntax presented in the referenced faq, at least for systems running systemd.  In short, steps 6) and 7) should read: 

sudo service [email protected] start|stop|status

The @server piece points to the server.conf file to be used, and cannot be passed as a separate parameter like the faq shows.  Using the proper syntax solved all of the issues shown above.  

In addition, the faq references another document about how to avoid manual entry of the username and password at each launch.  Learning the hard way I found that adding a new line near the beginning of the file doesn't help if there is an existing 'auth-user-pass' line below with no file being referenced, as the latter will execute and still request manual entry.  Editing the existing line instead of adding a new one solves the problem.

Share this post


Link to post
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...