Jump to content
TorGuard
  • 0
Sign in to follow this  
miguelrobulo

Cannot connect from Raspbian

Rate this question

Question

miguelrobulo

Hello everyone.

 

I am having troubles connecting. Thing is, until today everything was fine. Now, my vpn does not connect anymore. I am trying to troubleshoot it but nothing appears in /var/log/syslog (besides the messages for start and stop of the service).

 

I am trying to connect with:

sudo openvpn --daemon --cd /etc/openvpn --config TorGuard.Canada.Toronto.ovpn

From the /etc/openvpn folder. tun0 never comes up, and there are no messages in the log file.

 

Given that `killall -9 openvpn` returns "openvpn: no process found" I think that nothing is even remotely starting.

 

I can connect to TG from other machines using my account (same that is on the RPi).

 

I tried to re-download the configuration files, re-install openvpn, but nothing seems to work. 

 

How can I see what's going wrong?

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0
Support

Hi - when running this command - does the connection just hang?

 

try the following:

 

cd /etc/openvpn/

sudo mv TorGuard.Canada.Toronto.ovpn TorGuard.conf

sudo openvpn TorGuard.conf

 

Regards

Share this post


Link to post
Share on other sites
  • 0
miguelrobulo

Hi, 

I tried the solution in the above message, and the result is the same: no output whatsoever, and Tun0 does not come up.

Share this post


Link to post
Share on other sites
  • 0
ducky5

What is the status?

sudo service openvpn status

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×