Jump to content
TorGuard
  • 0
s22now

how to choose a specific ip/server?

Rate this question

Question

s22now

hello,

i seem to get a new ip address each time i reconnect to a server.  this create a problem for me because the application im using the vpn for keeps telling me to verify my account each time it detected a ip change

so is there way to manually choose which ip address i can connect to under each server location?

thanks

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0
Requa3r0

How is this done in a proper openvpn setup on a conf file in a linux environment.

Without this, I can not see how the port forwarding feature could ever work?

I am new to torguard, but have had PIA vpn for many hears, and here the ports are opened with a script and a unique ID, regardless of the issued IP

Share this post


Link to post
Share on other sites
  • 0
kurisu

Once you know the server IP and port you can set it up like any regular OpenVPN connection. The OpenVPN port is dictated by whether you wish to use port forwards or not and is provided in the port forward activation email after you configure one).

 

@johnnysmith you can "dig" the record for whichever country you want to connect through, and you'll see all possible servers returned. If you don't have a machine with the dig tool on, use Google's public DNS tools at https://toolbox.googleapps.com/apps/dig

All the server country-specific DNS records are available at https://torguard.net/network/ .

 

As my ISP has dodgy routing to some networks (for no obvious reason) I connected to over a dozen servers, running some iperf tests from my own and public iperf3 servers to determine which ones gave best throughput.

@Requa3r0 what you want is certainly possible, I do just this on my Synology. Once I found a server which performed well for me, I set up port forwards through Services -> My Services -> Manage menu (right hand side) and going to the Request Port Forward form.

I did have issues with port forwards not working unless I left the OpenVPN configuration to UDP and port 1912 on that form. Everything else is fine though, you can set up UDP and TCP forwards and also set them up across multiple servers. You'll get an email confirming this, then just set up as you would a custom profile or OpenVPN client.

Once on the VPN server associated with your port forward, run a listening server up on that port and use https://www.yougetsignal.com/tools/open-ports/ to determine if it's actually open. 

 

For my PC, when I want to use port forwards on that I just added custom profiles in the TorGuard Windows client. I also configured OpenVPN on my NAS using their OpenVPN Config generator (NB for my Synology I had to use the pre-2.3 OpenVPN build option); find the config generator at https://torguard.net/tgconf.php?action=vpn-openvpnconfig .

I applied that .ovpn file generated to the NAS and its openvpn client accepted and connected. Note this uses user and password auth (hashed and stored on the device), no idea about cert-based authentication, never bothered to try with TG.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...