Jump to content
TorGuard
  • 0

IKEV2 on iPhone


Taylor Brown

Question

Taylor Brown

Why is it that ikev2 through the TorGuard app on iPhone doesn't work? No matter what server, or network, it constantly keeps cycling through connecting and disconnecting.

Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0
Support

Why is it that ikev2 through the TorGuard app on iPhone doesn't work? No matter what server, or network, it constantly keeps cycling through connecting and disconnecting.

 

Hey Taylor

 

Unfortunately the ports required for IKEv2 are regularly blocked in networks - i would recommend you switch to Cisco IPSec if IKEv2 doesn't work for you.

 

Regards

Link to post
Share on other sites
  • 0
Taylor Brown

I contacted support about this issue, that's what they said. I know, for a fact, the ports are not blocked. It has connected before on this same network, and other vpns using ikev2 work fine. I've gone into my router settings to make sure the ports are not blocked.

Link to post
Share on other sites
  • 0
Support

I contacted support about this issue, that's what they said. I know, for a fact, the ports are not blocked. It has connected before on this same network, and other vpns using ikev2 work fine. I've gone into my router settings to make sure the ports are not blocked.

 

Have you tried the "Direct IP" profiles ? incase theres a DNS issue. Are giving it enough time to choose a server for you ?

Link to post
Share on other sites
  • 0
Support

Yes. If I put in the vpn settings manually in settings, it works fine. It's only through the app that it doesn't work.

 

Hmm here shouldn't be any difference - the iOS app uses the same settings as you would do setting up manually.

 

When setting up manually what hostname or IP do you use ?

Link to post
Share on other sites
  • 0
Taylor Brown

I put in the ip. Using the app I also choose direct ip. Right now ikev2 is working, and as long as I don't go into the app it seems to be fine. But the minute I go into the app it won't connect anymore.

Link to post
Share on other sites
  • 0
Support

I put in the ip. Using the app I also choose direct ip. Right now ikev2 is working, and as long as I don't go into the app it seems to be fine. But the minute I go into the app it won't connect anymore.

 

Ok, any chance we can do a small test ? i need to try find the root of the problem.

 

Regards

Link to post
Share on other sites
  • 0

Funny thing, it just now stopped working. Now it's back to connecting, disconnecting, and again and again

 

Taylor, we have a complete rewrite of the iOS app coming within a week - can you let us know if you still experience such problems ?

 

Thanks

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...